Announcement Announcement Module
No announcement yet.
Spring / Hibernate / CXF / Oracle Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring / Hibernate / CXF / Oracle

    Hello Guy's
    I have a little problems here to connect my webservice to an oracle database with Spring.

    Everything compile and run, but when i start my JUnit testing and all the DAO things is doing, ive got this uncomprehensible error here :

    INFO: Application has thrown exception, unwinding now: javax/transaction/SystemException

    I can't figure what is the problems, ive got no info, and no exceptions in my log files ...

    Here a couple of my configuration .

    PersistanceContext.xml :

        <?xml version="1.0" encoding="UTF-8"?><beans xmlns=""       xmlns:xsi=""       xmlns:aop=""       xmlns  =""       xmlns:tx=""       xmlns  wr=""       xsi:schemaLocation=""> 	<bean id="entityManagerFactory" 	  class="org.springframework.orm.jpa.LocalContainerEntityManagerFactoryBean">	  <property name="persistenceUnitName" value="SpringJpaSource"/>	   <property name="jpaVendorAdapter">	      <bean class="org.springframework.orm.jpa.vendor.HibernateJpaVendorAdapter">	        <property name="showSql" value="true" />             <property name="generateDdl" value="false" />             <property name="databasePlatform" value="org.hibernate.dialect.Oracle9iDialect" />             <property name="database" value="ORACLE" /> 	      </bean>	   </property>	</bean>		<bean id="dataSource"	   class="org.springframework.jdbc.datasource.DriverManagerDataSource">	    <property name="driverClassName" value="oracle.jdbc.OracleDriver"/>	    <property name="url" value="jdbc  racle:thin:@***.*******.com:1521:SERVER>	    <property name="username" value="*******"/>	    <property name="password" value="********"/>	</bean>		<tx:annotation-driven /> 		<bean class="" />   	<bean class="org.springframework.dao.annotation.PersistenceExceptionTranslationPostProcessor"/>		<bean id="transactionManager" class="org.springframework.orm.jpa.JpaTransactionManager">	      <property name="entityManagerFactory" ref="entityManagerFactory"/>	      <property name="dataSource" ref="dataSource"/>	</bean>	 	<bean id="mybean" class="com.nomdomaine.servicepackage.dao.myimplementation"/>	</beans> *************************************************** persistance.xml : <?xml version="1.0" encoding=  "UTF-8"?><persistence xmlns="" version="1.0">   <persistence-unit name="SpringJpaSource" transaction-type="RESOURCE_LOCAL"/></persistence>
    Maybe im doing some error in my configuration , im kind of little noob here.
    It will be great if someone can help me with that.