Announcement Announcement Module
Collapse
No announcement yet.
Which Hibernate version supported? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Which Hibernate version supported?

    I am using Spring with Hibernate for DAO, but ran into some problems. The Hibernate I used is 3.0 Beta3, while Spring seems to support eariler version. Which version of Hibernate does Spring support? Do I have to give up Hibernate 3.0 in order to use Spring?

    Thanks.

    Lilly

  • #2
    Spring currently supports Hibernate 2.1.x.

    Hibernate 3 is still in beta, so we can't release support for it as part of the core Spring release at this time. However (assuming the Hibernate team stick to their intended plan), Spring 1.2 will support Hibernate 3 in the core.

    There is already Hibernate 3 support for Spring in the Spring sandbox. See also the JIRA issue tracker. So you can start using the two together now, but you will need to use Spring code before it's official release, just as you would be using a beta version of Hibernate.

    Comment


    • #3
      Thanks, Rod. Looking forward to Spring 1.2.

      Also does Spring have plan to further support web serives? I know you currently support rpc type of services, what about document/literal type?

      Lilly

      Comment

      Working...
      X