Announcement Announcement Module
Collapse
No announcement yet.
awkward errors Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • awkward errors

    Hi there,

    I have an app (Spring + Hibernate); it's a simple application with MySql.
    I installed it on a linux server and, in the first hours everything was OK.
    In the evening I couldn't access the app, and I found this errors:

    at org.springframework.web.util.NestedServletExceptio n.getCause(NestedServletException.java:69)
    at javax.servlet.ServletException.getRootCause(Servle tException.java:96)

    Does someone have an idea why do I receive this errors?

    10x
    Adrian

  • #2
    Looks like you've missed copying most of the stack trace - pretty hard to diagnose the problem without it

    Comment


    • #3
      well...the truth is I don't what to copy...because the error isn't in my code....
      Look what I have found in the Tomcat's logs:

      Jun 29, 2007 8:30:49 AM org.apache.catalina.connector.CoyoteAdapter service
      SEVERE: An exception or error occurred in the container during the request processing
      java.lang.StackOverflowError
      at javax.servlet.ServletException.getRootCause(Servle tException.java:96)
      at org.springframework.web.util.NestedServletExceptio n.getCause(NestedServletException.java:69)
      at javax.servlet.ServletException.getRootCause(Servle tException.java:96)
      at org.springframework.web.util.NestedServletExceptio n.getCause(NestedServletException.java:69)
      at javax.servlet.ServletException.getRootCause(Servle tException.java:96)

      ....so it seems that the error is in the spring classes. what should I do?

      10x

      Comment


      • #4
        On the contrary, now that you've added more information, I can see that it is a StackOverflowError, which would normally occur if there's some infinite recursion in your code somewhere. The problem with StackOverflowError is that it is normally quite difficult to work out what the problem is simply with the stack trace because the JVM only prints out part of the stack trace since the stack is so huge due to the recursion.

        Is there no clue at the bottom of the stack trace? Perhaps check your code and make sure there is no infinite recusion happening within it.

        Comment


        • #5
          Thanks for your reply.

          I don't have anywhere recursion. The app is really small, even so, all my code is between try catch statement with the appropiate error description. Shouldn't that description been output too?

          Comment


          • #6
            more details:

            I deployed the app yesterday at 10:00 AM and I worked on it till 05:00 PM. Everything was ok...without any errors. The next next, when I tried to access it, I saw those errors.

            Maybe this can help you

            Comment


            • #7
              Sorry, its still too little information to go by.

              As for your exception description, I'm not surprised that it did not get outputted, this is because stack overflow errors tend to mask any underlying exceptions simply because the JVM is so overrun.

              Comment


              • #8
                the other possible reason you're not seeing your error description is because the StackOverflowError is a VirtualMachineError which is not a subclass of Exception.

                Comment


                • #9
                  You use a rather old version of Spring, don't you? Only those (up to Spring 1.2.7 and Spring 2.0 M3) have code in line 69 of NestableServletException at all. I can't really see what can cause the StackOverflowError though. In those old versions NestableServletException.getCause() indeed called getRootCause() whose implementation comes from ServletException. But I don't know how that one should be implemented to cause the StackOverflowError.

                  What are you doing with the exception? Something like printStacktrace(), toString(), getCause() or anything like that ...

                  Jörg

                  Comment


                  • #10
                    Hi,

                    Yes, I do a printStacktrace() but it's strange that I didn't find any information about this is my logs; all my code is between try catch statement.

                    Yes, I use a old spring version, but now I will try 2.0.6 version. I hope that will work.

                    Any ideas?

                    Comment


                    • #11
                      Replacing the old version with a new one, I don't have that error anymore

                      10x for the hint

                      Comment

                      Working...
                      X