Announcement Announcement Module
Collapse
No announcement yet.
Spring 1.1.3: JDK 1.3 compatibility is fully restored ??? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring 1.1.3: JDK 1.3 compatibility is fully restored ???

    when compiling the class org.springframework.jdbc.support.nativejdbc.Common sDbcpNativeJdbcExtractor, the compiler said "it needs java.sql.Savepiont". However, Savepiont is in JDK1.4.
    Therefore, I cannot compile Spring source code with JDK1.3.

  • #2
    Re: Spring 1.1.3: JDK 1.3 compatibility is fully restored ??

    From the readme.txt in the Spring distribution:

    The Spring Framework requires J2SE 1.3 and J2EE 1.3 (Servlet 2.3, JSP 1.2, JTA 1.0, EJB 2.0). J2SE 1.4 is required for building the framework...
    From what I understand, the JDK 1.3 compatibility should be about using the framework, instead of building it.

    Comment


    • #3
      Right, you can use it on 1.3, but you need 1.4 (or 1.5) to build it.

      Comment

      Working...
      X