Announcement Announcement Module
Collapse
No announcement yet.
Problem with Tomcat "-security" switch Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Tomcat "-security" switch

    Ok, I'm stumped. I've tried more or less everything I can think of, but nothing works:
    I ran into a strange problem while running spring (1.1.2) on tomcat (4.1.30). The problem has to do with hibernate (2.1), I think.

    Here's what happens: when I start my web apllication up, the ApplicationContext gets loaded and tries to init the DataSource and hibernate sessionfactory. However, when I run tomcat with the "-security" switch turned on, setting up the JDBC connections takes a lot longer than without the switch. So much so that running tomcat without security takes about 30 seconds less than with.
    This is really annoying, but it doesn't break the startup. After a while, everything does load and seem to be ok.

    I've tried turning on spring logging, but that doesn't help, it just hangs on the "opening JDBC connection" message for about 10 seconds. I've tried turning the tomcat security logging on, and got rid of every failure I could find by adding permissions in the catalina.policy file, but to no avail.

    Does anyone know what the problem might be?

    Greets,
    Maarten
Working...
X