Announcement Announcement Module
Collapse
No announcement yet.
mappingLocations. Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • mappingLocations.

    G'day,

    In the past I've been beating my head against the WasWall to have the hibbernate mappingfiles being loaded by Websphere (5.1.1) It all worked on my test environment but deploying it on a real server meant serious trouble.
    Our mapping files and generated base class files are stored inside a single utility jar living in an ear, a businessjar refers to this jar. We also have a war, refering the businessjar. [ear: business.jar generated.jar [war: other-classes]]
    We made the proper changes in manifest, and everything was working happily in WSAD 5.1. (XP) Test environment. Deploy to WAS 5.1 (on Solaris 9) gave an error indicating that mapping files cannot be found. I tried several things, classloader, strategies, mappingLocation/Resources and finally I found that mappingJars=WEB-INF/LIB/generated.jar is working, but this means a duplication of the jar: [ear: business.jar generated.jar [war: generated.jar]]. Not a very elegant solutions but we're quite experienced with inelegant solutions on WebSphere. This all works, but now our Problem:
    Junit tests wont work anymore because the war is of course not part of the junit tests. I'm looking right now for a solution to make a distinction for the loading of the generated jar:
    mappingLocations="nl/../**/*.hbm" for the junit/test env.
    mappingJar="WEB-INF/lib/genarated.jar" for the WAS/Solaris env.
    Someone with a suggestion or even a suggestion to have the mappingLocation work on WAS/Solaris?

    I'd be very thankfull!

    Kind regards,
    Jeroen Dijkmeijer.
Working...
X