Announcement Announcement Module
Collapse
No announcement yet.
Hibernate 3.1.x and Spring 1.2.7? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hibernate 3.1.x and Spring 1.2.7?

    I have been searching the forum to find an answer if this is working, but I can't find any.. There are some that says it will and some it won't.

    So I was just wondering if anyone could verify what is the correct answer, before I start wasting my time by changing the hibernate version...?

    Or is going straight to the 2.0 version the best option for a project that is going to be released during the next month? How stable is the 2.0M3 version?


    Regards,

    BTJ

  • #2
    AFAIK, Spring 2.0 m3 doesn't support all of HB 3.1.x addons. You can check the roadmap but I think that the new version of 2.0 and 1.2.8 will include some additional support.
    With 2.0, 1.2.x branch is going into maintainence mode so all the new features will go into 2.0.
    As a disclaimer, this is just my opinion and not something official.

    Comment


    • #3
      Well, I don't really need the 3.1 addons. What I want, are the bug fixes, so if I only use 3.0 features, the it will work?


      BTJ

      Comment


      • #4
        Well, I don't really need the 3.1 addons. What I want, are the bug fixes, so if I only use 3.0 features, the it will work?
        It should. Hibernate 3.1. and 3.0 are compatible (or at least they should be). Spring HB tries to use to reply on interfaces as much as possible and not be intrusive.

        Comment


        • #5
          Ok, I guess I just have to change library and try... Thx...


          BTJ

          Comment

          Working...
          X