Announcement Announcement Module
Collapse
No announcement yet.
Pb Oracle Blob bea wls 8.1sp2 hibernate 2.1.6 spring 1.1.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pb Oracle Blob bea wls 8.1sp2 hibernate 2.1.6 spring 1.1.1

    Hi,

    I have a problem by storing a blob field in the oracle db. It works well on Tomcat but not on Webblogic (classcast exception)
    -------------------------------------------
    In the applicationContext.xml
    <bean class="org.springframework.jdbc.support.lob.Oracle LobHandler" id="lobHandler">

    <bean
    class="org.springframework.orm.hibernate.LocalSess ionFactoryBean" id="sessionFactory">
    <property name="dataSource"> <ref bean="dataSource" />
    </property>
    <property name="lobHandler"><ref bean="lobHandler" /></property>
    ....

    ------------------------
    in the hibernate hbm file
    <property column="GI_BLOB" name="giBlob" type="org.springframework.orm.hibernate.support.Bl obByteArrayType"/>

    in the java class
    -------------------
    getHibernateTemplate().save(graphicalItem);

    thanks for your help
    Benoit

  • #2
    Can you please post more information about the actual exception. Are you using the WebLogic NativeJdbcExtractor?

    Comment


    • #3
      Dear Rod,

      We localise the problem. This problem comes from the oracle driver provided by weblogic 8.1sp2. We upgraded to weblogic sp3 and use the the *oracle thin driver 9.0.1,9.2,10

      Now it works fine

      Thanks a lot and to the spring team for the great product!
      Benoit

      Comment

      Working...
      X