Announcement Announcement Module
Collapse
No announcement yet.
ibatis : how to set AutoCommit mode to false Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • ibatis : how to set AutoCommit mode to false

    Hello,

    I am newbie to this forum, in case I post a wrong topic here, please kindly let me know.

    We have some applications using ibatis to run database queries in JDBC, but when we upgrade
    to SQL Server JDBC 3.0, we encounter this error when SQL Server statements raise excetpion.

    com.ibatis.dao.client.DaoException: Error ending JDBC transaction. Cause: com.microsoft.sqlserver.jdbc.SQLServerException: Cannot invoke a rollback operation when the AutoCommit mode is set to "true".

    I think the old JDBC driver does not handle this or now the new JDBC driver does not allow this type of settings.

    Do any expert here know if I can disable autocommit from ibatis config file?

    I really need your advice on fixing this.

    Thanks in advance,
    Ray
Working...
X