Announcement Announcement Module
Collapse
No announcement yet.
Spring Data JPA w/QueryDSL: OSGi problems Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Data JPA w/QueryDSL: OSGi problems

    Hi all,

    I'm trying to use Spring Data JPA 1.1.0.RC1 with the QueryDSL goodness in an OSGi environment, and I'm hitting problems. My biggest issues are that
    • QueryDSL expresses bundle dependencies either too restrictively (specific versions instead of version ranges),
    • QueryDSL expresses dependencies on things that aren't really required at runtime,
    • Spring Data JPA expresses a dependency on an old version of QueryDSL,
    • or some combination of the above.
    Can you guys add to the SpringSource EBR properly OSGi-ified QueryDSL bundles that are tested to work in OSGi? It seems to me that if Spring Data JPA is going to feature and express a dependency on QueryDSL, which is great, by the way, then Spring Data JPA should bear the burden of ensuring that libraries it deems worthy to depend on should be proper OSGi bundles.

    I'll enter issues to track this as well.

    Thanks,
    Matthew

  • #2
    Issues:

    https://jira.springsource.org/browse/DATAJPA-178

    https://issuetracker.springsource.com/browse/EBR-818

    https://github.com/mysema/querydsl/pull/73

    Several issues are similar at QueryDSL regarding OSGi:

    https://github.com/mysema/querydsl/issues/search?q=osgi

    My feeling is that Timo just might need a little advice on how the OSGi bundle manifest headers should best be crafted.

    -matthew

    Comment

    Working...
    X