Announcement Announcement Module
Collapse
No announcement yet.
Jpa 1.0? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jpa 1.0?

    I am wondering if I can use Spring Data JPA in the following environment:

    JBoss SOA 5.0.2 (Java EE 5, JPA 1.0, Hibernate 3.3.2)

    Thankfully, due to the JBoss Snowdrop project I have gotten Spring 3.0.6 to work in this environment...but in looking through the Maven dependencies it would appear to me that I may need a container with JPA 2.0 support in order to use Spring Data JPA. What is the truth?

  • #2
    42… You don't need a container but to ship a JPA 2.0 capable persistence provider along with your application. All the recent ones (Hibernate, EclipseLink, OpenJPA) implement the 2.0 version.

    Comment


    • #3
      Ah...so there's my problem. Based on your response I did a little research and found that Hibernate 3.5 was the first Hibernate version to support JPA 2.0, but I'm stuck with Hibernate 3.3.2. Hibernate seems so intertwined with this version of JBoss (5.0.x), that it may be quite difficult to "un-plumb" that. The obvious advice would be to upgrade JBoss (or switch to even just Tomcat), but that's unfortunately a very tough political battle.

      Thanks,
      Andy

      Comment


      • #4
        Andy,

        You might want to try to override the bootloader and tell the app server that the jars packaged with your app should be used and not the ones the app server provides. For an example of that read up on this link.

        http://www.openscope.net/2010/07/15/...class-loading/

        Hope this helps.

        -Andrew

        Comment


        • #5
          I have definitely been fighting the JBoss 5.0.x classloader and having mixed success. I've finally got Spring 3.0.6 to work with the "help" of the JBoss Snowbird project.

          One thing to note...your link just opens up to a splash page graphic with no text. Thanks for the link, though, and I'll try Googling the text to see if I find the article elsewhere.

          Originally posted by a.rubalcaba View Post
          Andy,

          You might want to try to override the bootloader and tell the app server that the jars packaged with your app should be used and not the ones the app server provides. For an example of that read up on this link.

          http://www.openscope.net/2010/07/15/...class-loading/

          Hope this helps.

          -Andrew

          Comment


          • #6
            Hmmmm ... I'm going to have to think about that one
            Attachment
            Attached Files

            Comment

            Working...
            X