Announcement Announcement Module
Collapse
No announcement yet.
Spring 2.5.6 Compatibility With Hibernate 3.6.5.Final Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring 2.5.6 Compatibility With Hibernate 3.6.5.Final

    Hi there,

    Please forgive me if I'm missing something that I should pick up by reading the respective manuals, but is Spring 2.5.6 compatible with Hibernate 3.6.5 Final?

    I've got what I believe to be the standard Spring 2.5.6 & Hibernate combo (see Maven config below), and whilst I do want to upgrade Spring to version 3 onwards, Hibernate is the priority.

    <!-- Spring -->

    <dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring</artifactId>
    <version>${org.springframework.version}</version>
    </dependency>

    <dependency>
    <groupId>org.springframework</groupId>
    <artifactId>spring-core</artifactId>
    <version>${org.springframework.version}</version>
    </dependency>

    <dependency>
    <groupId>org.hibernate</groupId>
    <artifactId>hibernate-core</artifactId>
    <version>3.3.2.GA</version>
    </dependency>
    <dependency>
    <groupId>org.hibernate</groupId>
    <artifactId>hibernate-annotations</artifactId>
    <version>3.4.0.GA</version>
    </dependency>
    <dependency>
    <groupId>org.hibernate</groupId>
    <artifactId>hibernate-commons-annotations</artifactId>
    <version>3.3.0.ga</version>
    </dependency>
    <dependency>
    <groupId>org.hibernate</groupId>
    <artifactId>hibernate-entitymanager</artifactId>
    <version>3.4.0.GA</version>
    </dependency>

    Thanks,
    Nico

  • #2
    I don't think it is… AFAIR we even had to change integration code for Spring 3.0 and Hibernate 3.4 so I'd really be surprised if 2.5.6 is compatible with Hibernate 3.6.x… And as 2.5.x is EOL for quite some time already I don't think we will ever see support for that scenario.

    Comment


    • #3
      Thanks for the reply Oliver. Time for me to migrate my project to Spring 3 then, and read the Hibernate section of the manual.

      Comment

      Working...
      X