Announcement Announcement Module
Collapse
No announcement yet.
Spring Data JPA -- Java 6 required? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Data JPA -- Java 6 required?

    I just wanted to verify that Java 6 is indeed required for Spring Data JPA. Can you confirm that?

    Thanks
    Andrew

  • #2
    It's not . What leads you to this assumption?

    Comment


    • #3
      I read a paragraph out of context from this blog [http://blog.springsource.com/2011/04...nd-querydsl/]:

      To cure that pain an open-source project called Querydsl has come up with a quite similar but also different approach. Just like the JPA Criteria API it uses a Java 6 annotation processor to generate meta-model objects but produces a much more approachable API.

      Does the integration with Querydsl require Java 6 (maybe just for the compilation)?

      Thanks
      Andrew

      Comment

      Working...
      X