Announcement Announcement Module
Collapse
No announcement yet.
Data JPA M2 compatibility Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Data JPA M2 compatibility

    I'm trying to use the M2 version of Spring Data JPA and I get a MalformedParameterizedTypeException.

    I've read in the forums this might come from a mismatch between Spring jars.
    I've tried with Spring 3.0.2, 3.0.5 and Spring 3.1M1 without success and there are no Spring 2 jars in the way.

    Which Spring version should I be using?

    JDK 1.6.0_24
    EclipseLink 2.2

  • #2
    Can you please post the type signatures (including generics) of the domain classes that use generics?

    Comment


    • #3
      The domain classes don't use generics, they are simple POJOs (implementing Serializable).

      Example:

      Code:
      @Entity
      public class Articulo implements Serializable
      This is a test project with a single DAO interface
      Code:
      public interface ArticuloDao extends JpaRepository<Articulo, Integer>
      and no custom implementation.

      Comment


      • #4
        [SOLVED]

        It seems it was a matter of missing dependencies. Changing the project to use Maven donwloaded a lot more jars and the problem went away.

        Comment

        Working...
        X