Announcement Announcement Module
No announcement yet.
[solved] How comes SpringCore does not find a Class ? Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • [solved] How comes SpringCore does not find a Class ?


    I modified the phonebook to add my own implementation of the PhoneBook interface. I change the bean's class in the xml file to the new class file.
    At run time, I have a log in tomcat logfile, coming from spring, that state that:

    INFO: Installation d'une application pour le chemin de contexte /phonebook depuis l'URL file:C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\phonebook
    2005-08-09 10&#58;52&#58;07,390 ERROR &#91;org.springframework.web.context.ContextLoader&#93; - <Context initialization failed>
    org.springframework.beans.factory.BeanDefinitionStoreException&#58; Error registering bean with name 'phoneBook' defined in class path resource &#91;org/springframework/webflow/samples/phonebook/deploy/service-layer.xml&#93;&#58; Bean class &#91;org.springframework.webflow.samples.phonebook.dao.PhoneBookImpl&#93; not found; nested exception is java.lang.ClassNotFoundException&#58; org.springframework.webflow.samples.phonebook.dao.PhoneBookImpl
    java.lang.ClassNotFoundException&#58; org.springframework.webflow.samples.phonebook.dao.PhoneBookImpl
    	at org.apache.catalina.loader.WebappClassLoader.loadClass&#40;;1340&#41;
    	at org.apache.catalina.loader.WebappClassLoader.loadClass&#40;;1189&#41;
    Of course, at first, i believed that i had mispelled something. But after checking 3 times, the bean declaration, the class name, it's location in the "classes" directory, i can't find any. So I wondering if there may not be an another reason for the error...
    Do you have any clues ? Or idea ? I'm quite open to suggestion right now... :cry:


  • #2
    I don't realy know how buti solved it ...