Announcement Announcement Module
Collapse
No announcement yet.
upgrade from 1.2.8 to 2.5.6 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • upgrade from 1.2.8 to 2.5.6

    Last week I tried to upgrade an application from Spring 1.2.8 to 2.5.6.

    After added the 2.5.6 Spring libs to the project and restarting the application I was welcomed with a bunch of exceptions: bean dependency exceptions, bean creation in progress, .... Seems Spring 2.5.6 does not like the order in which the beans were declared in this project. It worked correctly with Spring 1.2.8 though.

    What has changed in the dependency mechanism from 1.2.8 to 2.x.x? Any help greatly appreciated, I hope I do not have to reorder the beans in the several application context XML files this project has.

  • #2
    The order of beans in the Spring config means nothing.

    How about you be more specific about the structure of your application, including excerpts from your Spring configs, along with the actual detailed error messages you're getting?

    Comment


    • #3
      hi,


      see below:

      nested exception is org.springframework.beans.factory.BeanCurrentlyInC reationException: Error creating bean with name 'generateDocumentInterceptor': Requested bean is currently in creation: Is there an unresolvable circular reference?

      Comment


      • #4
        hi,


        seems that this interceptor is a org.springframework.aop.support.NameMatchMethodPoi ntcutAdvisor. It had singleton="false" which I changed to scope="prototype" after replacing the old DTD with the new XSD. After removing the prototype scope everything seems to work fine. Any ideas?

        Comment

        Working...
        X