Announcement Announcement Module
Collapse
No announcement yet.
White spaces are required between publicId and systemId. Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    BTW, I had this very same problem on Tomcat 6.0.29 and I did move the appContext file from WEB-INF/appContext.xml to WEB-INF/somefolder/appContext.xml and the problem went away.

    I am not sure why all XMLs under WEB-INFs are validated.

    There should be a real solution to this problem like making the web server actually understand the contents of the XML.

    Comment


    • #17
      Originally posted by GMur View Post
      BTW, I had this very same problem on Tomcat 6.0.29 and I did move the appContext file from WEB-INF/appContext.xml to WEB-INF/somefolder/appContext.xml and the problem went away.
      Unfortunately putting the spring config to a separate directory under WEB-INF did not solve the problem for me ...

      I am using Spring 3.0.4-RELEASE with Tomcat 6.0.29, Java 1.6.0_21-b07. (same problem with Spring 2.5.6)

      ... and having problem with this namespace:
      http://jax-ws.dev.java.net/spring/servlet

      at
      <wss:binding url="/lrequest" service="#myJAXWSWebService" />

      with jaxws-spring-1.8.jar

      Any ideas?

      Comment


      • #18
        arghh... this was environmental problem by me...
        My Eclipse (3.5) does not deploy properly the jars which are put to the Build path into the embedded Tomcat server instance.
        The problem does not occur, if I make a war and deploy it to a stand-alone Tomcat.
        Moreover the IDE still marks the wss namespace as an error (in spite I have added it to Preferences/XML/XML catalog). brrr...
        Last edited by firesign; Sep 21st, 2010, 04:56 PM.

        Comment


        • #19
          Using Spring 2.5.6, I saw the exception: org.xml.sax.SAXParseException: White spaces are required between publicId and systemId when my <beans> tag was defined as:
          Code:
          <beans xmlns="http://www.springframework.org/schema/beans"
          	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          	xmlns:context="http://www.springframework.org/schema/context"
          	xmlns:webflow="http://www.springframework.org/schema/webflow-config"
          	xsi:schemaLocation="
          		http://www.springframework.org/schema/beans
          		http://www.springframework.org/schema/beans/spring-beans-2.5.xsd
          		http://www.springframework.org/schema/webflow-config
          		http://www.springframework.org/schema/context
          		http://www.springframework.org/schema/context/spring-context-2.5.xsd
          		http://www.springframework.org/schema/webflow-config/spring-webflow-config-2.0.xsd">
          Switching it to:
          Code:
          <beans xmlns="http://www.springframework.org/schema/beans"
          	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          	xmlns:context="http://www.springframework.org/schema/context"
          	xmlns:webflow="http://www.springframework.org/schema/webflow-config"
          	xsi:schemaLocation="
          		http://www.springframework.org/schema/beans
          		http://www.springframework.org/schema/beans/spring-beans-2.5.xsd
          		http://www.springframework.org/schema/context
          		http://www.springframework.org/schema/context/spring-context-2.5.xsd
          		http://www.springframework.org/schema/webflow-config
          		http://www.springframework.org/schema/webflow-config/spring-webflow-config-2.0.xsd">
          solved the problem for me.

          Comment

          Working...
          X