Announcement Announcement Module
Collapse
No announcement yet.
Which ANTLR to use with 3.0 M1? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    i also got this error using org.springframework.core-3.0.0.M3.jar and hibernate 3.3.1.GA.

    i've already added antlr 2.7.7 and 3.1.3.

    any ideas?
    Last edited by neodagzph; May 20th, 2009, 02:54 AM. Reason: added query

    Comment


    • #17
      I opened a JIRA issue foe this, which was never resolved, but the issue seems to have resolved itself from M2 onwards (for me, at least)

      http://jira.springframework.org/browse/SPR-5343

      You might want to add more info to the issue.

      Comment


      • #18
        just got mine working today. Used the previous posts on antlr versions
        (2.7.7 and 3.0.1) on Hibernate3 and Spring3.

        http://img193.imageshack.us/img193/8...te3spring3.png
        Last edited by neodagzph; May 20th, 2009, 09:12 PM. Reason: added picture for reference

        Comment


        • #19
          It only works with antlr-3.0.1.jar. I just downloaded and it works fine now.

          Comment


          • #20
            Originally posted by vw729 View Post
            Caused by: java.lang.NoClassDefFoundError: antlr/ANTLRException
            org.hibernate.hql.ast.ASTQueryTranslatorFactory.cr eateQueryTranslator()
            ...
            How to solve this problem then?
            You need the antlrworks jar file in your classpath. I am using the antlrworks-1.2.3.jar and it works fine.

            Comment


            • #21
              I'm using Spring framework 2.5, spring security 2.0.4 and Hibernate 3. After reading this post, I downloaded and added the antlr-3.0.1.jar to my classpath (I tried with antlr 2.7.5 as well), but unfortunately when I try to compile my webapp the following error appear in catalina log:

              java.lang.NoSuchFieldError: ruleMemo

              I got lost with your configurations.. any suggestion with this configuration???
              Many thanks!

              Comment


              • #22
                I am using spring-framework-3.0.0.M3 and trying to make this work with antlrworks-1.2.3.jar , antlr-runtime-3.1.3.jar but still get the error


                Exception in thread "main" java.lang.NoSuchFieldError: ruleMemo
                at org.springframework.expression.spel.generated.Spri ngExpressionsParser.<init>(SpringExpressionsParser .java:94)

                Comment


                • #23
                  The dependency on Antlr has been removed, but you need something more recent that 3.0.0M3. The expression support now uses its own parser with no antlr requirement. If you grab a recent 3.0.0RC snapshot you will not have this problem.

                  Andy Clement
                  Senior Software Engineer
                  SpringSource

                  Comment


                  • #24
                    I could not find RC release. If I go in there I still see M3.
                    http://www.springsource.com/download/community?project=
                    With RC do you mean nightly build ? Can you please provide the link ?

                    Comment


                    • #25
                      For anyone looking for it the source can be found here: https://src.springframework.org/svn/spring-framework/


                      Originally posted by vinay076 View Post
                      I could not find RC release. If I go in there I still see M3.
                      http://www.springsource.com/download/community?project=
                      With RC do you mean nightly build ? Can you please provide the link ?

                      Comment

                      Working...
                      X