Announcement Announcement Module
Collapse
No announcement yet.
[solved] Quartz job scheduling OK locally but fails on JBoss Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • [solved] Quartz job scheduling OK locally but fails on JBoss

    Hi all,

    I have a fairly simple Quartz scheduling setup: 1 trigger, 1 job. It works perfectly when I unit test my app locally, but when I deploy it under JBoss 4.0.1 (same Spring context) my job is never triggered... In both cases (locally or deployed), I can't find any traces of the scheduling beans creation at startup.

    The following is an extract of my Spring context.

    Code:
    <!-- Quartz Job for calling SystemService.refresh&#40;&#41; method -->
        <bean id="refreshJob"
            class="org.springframework.scheduling.quartz.MethodInvokingJobDetailFactoryBean">
            <property name="targetObject">
                <ref bean="systemService" />
            </property>
            <property name="targetMethod">
                <value>refresh</value>
            </property>
        </bean>
    
        <!-- Quartz refresh trigger. Fires refresh job -->
        <bean id="refreshTrigger" class="org.springframework.scheduling.quartz.SimpleTriggerBean">
            <property name="jobDetail">
                <ref bean="refreshJob" />
            </property>
            <property name="startDelay">
                <!-- 2 seconds -->
                <value>2000</value>
            </property>
            <property name="repeatInterval">
                <!-- repeat every 1 second&#40;s&#41; -->
                <value>1000</value>
            </property>
        </bean>
    
        <!-- Quartz scheduler -->
        <bean class="org.springframework.scheduling.quartz.SchedulerFactoryBean">
            <property name="triggers">
                <list>
                    <ref local="refreshTrigger" />
                </list>
            </property>
        </bean>
    Has anybody been experiencing this kind of weird behavior?

    Thanks for your answers. Regards,
    Baptiste

  • #2
    I use Quartz/Spring on JBoss 4.0.1 no probs.

    Can you make sure you have the debugging level set to DEBUG in log4j.xml and verify that the beans are definitely not being created.

    If they're not being created, is the Spring .xml file with the Quartz beans being loaded? i.e. what's your web.xml look like?

    I'm not at the JBoss machine right now, am at another Spring/Oracle project so can post my config if you're still having trouble. Let me know.

    Comment


    • #3
      It turned out to be a simple trace problem not related to Quartz or Spring.

      Thanks for your answer and sorry for the noise.

      Baptiste

      Comment


      • #4
        Can you please let me how you have resolved this issue? As I also facing the same problem....

        Comment

        Working...
        X