Announcement Announcement Module
Collapse
No announcement yet.
standalone spring app, exception loading context from xml file Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I see I'm not the only one to not see a reply before replying amd not only one
    to accidently cobble together the wrong library sets.
    My (phill) and ew0kian's solution was to get all of the org.slf4j libraries aligned to the same (latest) version and the problem went away because the name field was recently added, so this erros comes up if you mix more recent versions
    with slightly older versions.

    HTH

    Comment


    • #17
      Originally posted by dendery View Post
      I have fixed it!
      My problem was due to incompatible versions of the components of the slf4j library.
      The project used the following:
      slf4j-api-1.5.2.jar
      slf4j-log4j12-1.5.3.jar
      but they aren't compatible.

      slf4j-api-1.5.2.jar was replaced by slf4j-api-1.5.3.jar and now it works!
      Hi, can some1 help me get this file [slf4j-api-1.5.3.jar] please ... googled with no success

      Comment


      • #18
        And on the slf4j site (http://www.slf4j.org)?
        Originally posted by SonxSprn7 View Post
        Hi, can some1 help me get this file [slf4j-api-1.5.3.jar] please ... googled with no success

        Comment


        • #19
          Which version of slf4j are you using?

          I was using slf4j-log4j12-1.5.3.jar because I downloaded it manually from the slf4j site but the dependency states slf4j-1.5.2. Once I got the 1.5.2 the NoSuchFieldError was gone.

          Comment


          • #20
            Which dependency do you mean?
            And I really doubt that any dependecy states mix of 1.5.2 and 1.5.3
            Originally posted by szafir View Post
            I was using slf4j-log4j12-1.5.3.jar because I downloaded it manually from the slf4j site but the dependency states slf4j-1.5.2. Once I got the 1.5.2 the NoSuchFieldError was gone.

            Comment


            • #21
              Hi, Were you able to resolve the problem. Pls share your findings.

              regds

              Comment


              • #22
                what is your question Vijay?

                Comment


                • #23
                  Am Sorry. I posed it by mistake. Pls ignore.

                  regards

                  Comment


                  • #24
                    Cannot find class [org.springframework.orm.hibernate3.LocalSessionFac toryBean]

                    hello every one.
                    i'm working on eclipse RCP with Spring and Hibernate, when i run the rcp application, i've got the error:" Cannot find class [org.springframework.orm.hibernate3.LocalSessionFac toryBean]".
                    Then i added the Spring.jar(which contains the class LocalSessionFactoryBean) to the classpath, but i always got the same error.
                    Please i need your help

                    Comment


                    • #25
                      Hi, Can you please copy the full stack trace and if possible code snippet.

                      regds

                      Comment


                      • #26
                        it seems to be resolved,I no longer receive this error :"Cannot find class [org.springframework.orm.hibernate3.LocalSessionFac toryBean]".
                        i retrieved the librairies of Spring and Hibernate and created 2 folder for each one, i added all the jars of Spring(7 jars) and hibernate3 to the class path.
                        here the classPath, it may help :

                        <code>
                        <?xml version="1.0" encoding="UTF-8"?>
                        <classpath>
                        <classpathentry exported="true" kind="lib" path="Hibernate/hibernate3.jar"/>
                        <classpathentry exported="true" kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.Standar dVMType/JavaSE-1.6"/>
                        <classpathentry exported="true" kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
                        <classpathentry kind="src" path="src"/>
                        <classpathentry kind="src" path="hibernate-config"/>
                        <classpathentry kind="src" path="spring-config"/>
                        <classpathentry exported="true" kind="lib" path="Spring/spring.jar"/>
                        <classpathentry exported="true" kind="lib" path="Spring/aspectjrt.jar"/>
                        <classpathentry exported="true" kind="lib" path="Spring/aspectjweaver.jar"/>
                        <classpathentry exported="true" kind="lib" path="Spring/cglib-nodep-2.1_3.jar"/>
                        <classpathentry exported="true" kind="lib" path="Spring/commons-logging.jar"/>
                        <classpathentry exported="true" kind="lib" path="Spring/junit-3.8.2.jar"/>
                        <classpathentry exported="true" kind="lib" path="Spring/log4j-1.2.15.jar"/>
                        <classpathentry kind="output" path="bin"/>
                        </classpath>
                        </code>

                        thanks VijayS for your respnse.

                        Comment


                        • #27
                          Originally posted by szafir View Post
                          I was using slf4j-log4j12-1.5.3.jar because I downloaded it manually from the slf4j site but the dependency states slf4j-1.5.2. Once I got the 1.5.2 the NoSuchFieldError was gone.
                          Is people are still active on this thread, I am getting the same error. I tried with slf4j-api-1.5.3.jar and slf4j-log4j12-1.5.3.jar. No success. any help would be appreciated.

                          Comment

                          Working...
                          X