Announcement Announcement Module
Collapse
No announcement yet.
<bean class="${...}"/> Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • spgmx
    started a topic <bean class="${...}"/>

    <bean class="${...}"/>

    Hi,

    it seems that <bean class="${...}"/> with a property placeholder does not always work. No clue why it sometimes does the job and sometimes not.

    The property gets resolved but when the class shall be loaded a ClassNotFoundEx is thrown ("${...}" not found).

    Any ideas?

    Thank you.

  • spgmx
    replied
    Well, the property gets resolved and I have only one PPHC defined.

    Leave a comment:


  • lucasward
    replied
    It's my understanding that in 2.5 if you use a placeholder, it will default to looking for it in system properties if no placeholder is configured. I've had some other issues with this as well. For example, if you have more than one configurer declared, you will run into some issues as well. Or at least I had problems when doing so in 2.0.x

    Leave a comment:


  • spgmx
    replied
    Well I tought it was the switch from 2.0 to 2.5.
    But some days ago a customer had the same error with 2.0.5.

    What do you mean with "don't actually have to declare the placeholderconfigurer"?

    Leave a comment:


  • lucasward
    replied
    What version of spring are you using? There's been some changes to how this works in some of the later versions. Specifically, you don't actually have to declare the placeholderconfigurer in later versions.

    Leave a comment:

Working...
X