Announcement Announcement Module
Collapse
No announcement yet.
Problems upgrading to the current release Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems upgrading to the current release

    Hi, I'm getting a strange error when I try to upgrade my spring jar from 2.0-m2 to the current production release 2.06. I have the following bean definition:

    <bean id="PASportJob" class="org.springframework.scheduling.quartz.Metho dInvokingJobDetailFactoryBean">
    <property name="targetObject"><ref bean="PASport_ConfigBean"/></property>
    <property name="targetMethod"><value>execute</value></property>
    <property name="concurrent"><value>false</value></property>
    </bean>

    Which gives the following error.

    Unexpected failure during bean definition parsing; nested exception is java.lang.NoSuchMethodError: org.springframework.util.ClassUtils.getConstructor IfAvailable(Ljava/lang/Class;[Ljava/lang/ClassLjava/lang/reflect/Constructor

    I cant see any reason why it should be any diffrerent, hope someone can help.

  • #2
    Do you have duplicate JARs on the classpath?
    Last edited by karldmoore; Aug 27th, 2007, 03:13 PM.

    Comment


    • #3
      No I removed the first jar and made sure that all the classes could not be found, then added the new one, re-compiled and redeployed

      Comment


      • #4
        Hmmm that's usually the cause of such issues. Is there any chance you can post the full stacktrace in [code] [ /code] tags.
        Last edited by karldmoore; Aug 27th, 2007, 03:13 PM.

        Comment

        Working...
        X