Announcement Announcement Module
Collapse
No announcement yet.
JUnit 4.X in Spring 2.1 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • JUnit 4.X in Spring 2.1

    Hi!

    As I have been told Spring 2.1 (and hence 2.1-m2?) is supposed to support JUnit 4.x, but looking at the .pom file downloaded from https://springframework.svn.sourcefo...epo-snapshots/ 2.1-m2 still depends on junit 3.8.1. Is this intentional or a glitch?

    ...I can't find a way to search the forum for "junit 4" (the brilliant search engine interprets that into two words: '"junit' and '4"') so I'm sorry if this question has already been answered... :-)

    cheers
    -Martin

  • #2
    Try "JUnit 4" including the " that might help.

    However the issue related to this is planned for M3 so you will have to wait a little more.

    Comment


    • #3
      Originally posted by mdeinum View Post
      Try "JUnit 4" including the " that might help.

      However the issue related to this is planned for M3 so you will have to wait a little more.
      Thanks, that sort of explains it! ...I'll just wait until 2.1-m3 is released then (July 7 if I'm correct).

      ...regarding your search tip: that's what I did (using the ":s around the words) but that gave me the following result:
      Search: Key Word(s): "JUnit
      The following words are either very common, too long, or too short and were not included in your search: 4"

      Comment


      • #4
        Hmm tried with a single 'junit 4' I keep forgetting how to do that

        Comment


        • #5
          ...doesn't work either... but since you were quick enough to answer my main question I don't have to be annoyed over the search functionality anymore!

          Comment

          Working...
          X