Announcement Announcement Module
Collapse
No announcement yet.
rmi exception out of the blue Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • rmi exception out of the blue

    all, sorry for the crosspost b/w here and the rmi board. didn't get any feedback yesterday so i'm trying it out here.

    This one came up out of the blue yesterday and only affects my dev server, not the actual server on which the application runs. Haven't had a need to run my junit tests in about a month. today, i ran them, and I get this error:

    Caused by: org.springframework.beans.factory.BeanCreationExce ption: Error creating bean with name 'serviceExporter' defined in class path resource [com/argus/pola/application/props/applicationContext.xml]: Invocation of init method failed; nested exception is java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
    java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
    java.lang.ClassNotFoundException: null (no security manager: RMI class loader disabled)

    I can think of nothing at all that's changed in the system to warrant this message.

    here's my export in applicationContext.xml:

    <bean id="serviceExporter" class="org.springframework.remoting.rmi.RmiService Exporter">
    <property name="service">
    <ref local="polarunner"/>
    </property>
    <property name="serviceInterface">
    <value>blah.OptimizerRunner</value>
    </property>
    <property name="serviceName">
    <value>POLARunner</value>
    </property>
    </bean>


    I've not needed a policy file before. so i put one together with all permissions granted, then called System.setProperty("java.security.policy","rmi.pol icy") before the call to new ClassPathXMLApplicationContext(blah.xml).... I tried passing the file as a jvm argument...still the same thing.

    Any advice?

  • #2
    uggg, just awful. there was one thing that changed...a new version of coldfusion was installed on my dev machine. i have no idea how, since I thought that ran in complete isolation, jvm-wise, but that's what was causing it.

    Comment

    Working...
    X