Announcement Announcement Module
Collapse
No announcement yet.
Java Version Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Java Version

    Hi there,
    can anyone tell me what version(s) of Java the latest releases of Spring will run under?

    For example, will "Spring 1.1 RC1" run under java 1.3?

    Thanks,
    Peter

  • #2
    to run it 1.3 is fine, to build it you need 1.4+

    Regards,

    Comment


    • #3
      Certain features work faster under 1.4, e.g. AOP if you use dynamic proxies, rather than CGLIB will be significantly faster in 1.4.

      But Spring is supported on and works well under 1.3, and falls back to the 1.3 feature set if required. Some of the largest enterprise users of Spring are on 1.3, as they are still on relatively old app server versions.

      Comment

      Working...
      X