Announcement Announcement Module
Collapse
No announcement yet.
SEVERE: Error listenerStart - finding the error Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Also struggleing with this problem

    Hi there,
    I have this same problem here with the listener and it gets even worse because I can't debug either :-(

    I don't really understand how you guys did it actually since there is a problem with the JVM that crashes whenever I try to open the manager while in debug mode, and since you can only deploy an application with the manager I fail to understand how you debugged this.

    Comment


    • #17
      Two things that helped me found issue cause:

      1) Used 'Any exception' breakpoint in IntelliJ (don't know if there same option in Eclipse) and realized that Loggers are not loaded properly (perhaps because of other blocking issues) and that's why no stacktrace was printed.

      2) Removed all loggers from project (log4j.jar, commons-logging.jar, log4j.properties) and started again - received my error in console via default spring logging. Voila

      Comment


      • #18
        Well this is how I solved it:

        Installed a new instance of tomcat...

        that's right, I simply installed a new instance of tomcat, and my application deployed just nicely on it, started with no fail. I then simply defined a new tomcat worker, configured all the ports, virtual hosts, AJP and there ya go, finally it works. Tough workaround, but I'm satisfied.

        Comment


        • #19
          I had this yesterday, I was just about to set up eclipse with all the sources to debug, I talked to a colleague and he mentioned he'd had it also.

          What worked for me was removing tomcat, reinstating a fresh install, starting it, then copying the .war file in the webapps folder. I had previously tried removing and reinstalling tomcat and cpying the war to the webapps folder prior to starting, receiving the same SEVERE: Error listenerStart error. It seems starting tomcat first made all the difference.

          Comment


          • #20
            SEVERE: Error listenerStart - finding the error

            A simple way to get the complete stack trace is to create a unit test that initializes all beans with your servlet.xml and execute it. Set the log level for spring to debug. Usually I get the error if I removed some property from a bean but forgot to remove the parameter from the servlet.xml.

            I include a static block into the unit test for initialization:
            static {
            System.err.println("working dir: " + System.getProperty("user.dir"));
            PropertyConfigurator.configure(".." + System.getProperty("file.separator") + "log4j.properties");

            String paths = "servlet.xml";
            ClassPathXmlApplicationContext applicationContext =
            new ClassPathXmlApplicationContext(paths);
            }

            Comment


            • #21
              log4j.logger.org.springframework.web.context=debug , stdout

              This line in my log4j.properties made the trick and showed me what was the error right away

              Hope it helps somebody out there... .. cheers

              Comment


              • #22
                Worked for me

                Hi everybody.
                dont know this might work for u.
                i was having this error, with one line on tomcat sonsole. saying severe -- listener error. and thing else printed in console in tomcat.
                could not understand what was causing the problem.
                after reading this thread, i understood its some kind of logging configuration problem
                then i looked at my log4j.properties, and realised it was not setup for a console log, but was set for a rolling file appender, writing to some file in my file system test.log
                here is my logj configuration for rolling file.

                and this was writing to test.log,
                i was unable to find this log in tomcat logs folder.
                but it was writing to CATALINA_HOME/bin/test.log
                there in that log, i was able to see why the spring was not failing to load.

                # ROLLING
                log4j.appender.ROLLING=org.apache.log4j.RollingFil eAppender
                log4j.appender.ROLLING.File=test.log
                log4j.appender.ROLLING.layout=org.apache.log4j.Pat ternLayout
                log4j.appender.ROLLING.layout.ConversionPattern=%d {ISO8601} %-5p %c{1}-%m%n
                log4j.appender.ROLLING.MaxFileSize=10MB
                log4j.appender.ROLLING.MaxBackupIndex=5


                one more this that might help, is my spring application-context.xml contaisn an entry for loading log4j.

                <bean id="log4jInitialization"
                class="org.springframework.beans.factory.config.Me thodInvokingFactoryBean">
                <property name="targetClass"
                value="org.springframework.util.Log4jConfigurer" />
                <property name="targetMethod" value="initLogging" />
                <property name="arguments">
                <list>
                <value>classpath:log4j.properties</value>
                </list>
                </property>
                </bean>

                make sure u have similar entry that helps spring intialize and write to log4j.

                hope this helps
                thanks
                Nagolu Sidhartha

                Comment


                • #23
                  remove log4j from WEB-INF/lib

                  I have found that what works for me (just had to do it again, and it still worked) is to remove the log4j jar from WEB-INF/lib within your webapp, and have it only in tomcat/common/lib

                  After restarting tomcat I get lots of useful error messages.

                  Note that if you are using maven, remember to clean after updating your pom.xml, or the log4j jar will still be there.

                  Hope this helps someone!

                  Comment


                  • #24
                    check dis blog

                    http://skc-ebooks.blogspot.com

                    i posted a systematic way to solve the error

                    Comment


                    • #25
                      I had the same problem.
                      I was working on two different projects, one that runs in JRE 1.5 and the other runs on JRE 1.6. The problem was that I was trying to start tomcat with a project compiled with Java 1.6 on the JRE 1.5.
                      Hope it helps.

                      Comment


                      • #26
                        Thanks Sidhartha Your solution worked

                        Thanks Sidhartha Your solution works

                        Comment

                        Working...
                        X