Announcement Announcement Module
Collapse
No announcement yet.
ReloadableResourceBundleMessageSource broken in nightly Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • ReloadableResourceBundleMessageSource broken in nightly

    I have been using the "ReloadableResourceBundleMessageSource" to load my message sources but it seems recently this has stopped working..

    What I had before was:
    Code:
        <bean id="messageSource" class="org.springframework.context.support.ReloadableResourceBundleMessageSource">
            <property name="basenames">
                <list>
                    <value>com/vodori/dolce/web/resources/applicationResources</value>
                </list>
            </property>
            <property name="useCodeAsDefaultMessage" value="false"/> 
            <property name="cacheSeconds" value="3"/>
        </bean>
    but that was not finding any of my messages and so just to see what would happen, I switched it to the normal "ResourceBundleMessageSource" and it's working just fine.. So this snip of code does work:

    Code:
        <bean id="messageSource" class="org.springframework.context.support.ResourceBundleMessageSource">
            <property name="basenames">
                <list>
                    <value>com/vodori/dolce/web/resources/applicationResources</value>
                </list>
            </property>
            <property name="useCodeAsDefaultMessage" value="false"/>
        </bean>

  • #2
    Oops. I should have posted this under the "Web" forum. Sorry about that.

    Comment


    • #3
      Created JIRA issue to track:
      http://opensource.atlassian.com/proj...rowse/SPR-2319

      Comment


      • #4
        Could you test your code against a stable build? If the error persists please raise an issue on jira. Thanks!

        Comment


        • #5
          You read my mind... over the wire! Thanks for the feedback - it is very important for us as we can't fix bugs we don't know about.
          Last edited by Costin Leau; Jul 18th, 2006, 04:58 PM. Reason: I keep having too many smilies then intended

          Comment


          • #6
            I did test this with Spring 1.2.x and it does work fine. In fact, I actually took a web app based on 1.2.x, made a copy which included the Reloadable resource bean, put in Spring 2.0RC3 (nightly) and have been working on it for a few weeks only to recently start adding in resource bundles which is when I ran into this problem...

            I'm not sure if any certain Spring 2.x build broke it unfortunately but I do know it worked just fine in 1.2.x

            Thanks!

            Comment

            Working...
            X