Announcement Announcement Module
Collapse
No announcement yet.
Does Spring 1.2.8 work with Hibernate 3.2.0.cr2? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Does Spring 1.2.8 work with Hibernate 3.2.0.cr2?

    Does Spring 1.2.8 work with Hibernate 3.2.0.cr2?, I am mapping my model layer with annotations and I wonder if I could still use Spring 1.2.8 or do I need to upgrade to Spring 2.0 -RC1 for the DAOs? Most likely I won't need Java 5 new sintax features on the DAO layer, but I was wondering if would work Spring 1.2.8 will work with Hibernate 3.2.0.cr2 as I won't be generating *.hbn.xml files.

    And also, how do I specify the mappingResources in the applicationContext? In the following sample would this:
    Code:
    my/company/model/MyClass.hbm.xml
    need to be replaced by:
    Code:
    my.company.model.MyClass
    ?
    Code:
    <property name="mappingResources">
                <list>
                  <value>my/company/model/MyClass.hbm.xml</value>
                    
                </list>
            </property>
    Is there any documentation explaining how to do it? Please let me know. Thanks!
    Last edited by seth; Jun 27th, 2006, 03:55 PM.

  • #2
    See org.springframework.orm.hibernate3.annotation.Anno tationSessionFactoryBean.
    Its javadoc is quite explanatory.

    Comment


    • #3
      I would rather upgrade it to SPring 2.0 fo better usage.

      Comment

      Working...
      X