Announcement Announcement Module
Collapse
No announcement yet.
Error registering bean Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error registering bean

    Hello,

    When I start my application in tomcat 4.1 appears this errors:

    15:04:19,591 ERROR ContextLoader:205 - Context initialization failed
    org.springframework.beans.factory.BeanDefinitionSt oreException: Error registering bean with name 'productDao' defined in ServletContext resource [/WEB-INF/applicationContext.xml]: Bean class [es.castinfo.iComponents.exemple.model.dao.hibernat e.ProductDaoHibernate] not found; nested exception is java.lang.ClassNotFoundException: es.castinfo.iComponents.exemple.model.dao.hibernat e.ProductDaoHibernate
    Caused by:
    java.lang.ClassNotFoundException: es.castinfo.iComponents.exemple.model.dao.hibernat e.ProductDaoHibernate


    I have put ProductDaoHibernate class in es.castinfo.iComponents.exemple.model.dao.hibernat e pacakge.

    My libraries are:

    antlr-2.7.6.jar
    aopalliance.jar
    c3p0-0.9.0.4.jar
    cglib-nodep-2.1_3.jar
    commons-beanutils-1.7.0.jar
    commons-codec-1.3.jar
    commons-collections-3.1.jar
    commons-digester-1.6.jar
    commons-fileupload.jar
    commons-lang-2.1.jar
    commons-logging-1.0.4.jar
    dom4j-1.6.1.jar
    ehcache-1.2.jar
    hibernate3.jar
    jsf-api.jar
    jsf-impl.jar
    jstl.jar
    jta.jar
    log4j-1.2.13.jar
    spring.jar
    standard.jar

    Somebody can help me?

  • #2
    Make sure the class is defined properly (declared in the proper package) and that it resides under WEB-INF/classes. If you need help in setting up your application see the samples from Spring distribution or google around for some tutorial (see springhub.com) - that is unless you already have a book on Spring which comes with examples.

    Comment


    • #3
      What jar file is your application named? I didn't see it on the list.

      Good Luck,

      Steve O

      Comment


      • #4
        Hello Costin,

        Really, this problem appears when I'm trying to use Eclipse 3.2 with JSF Tools Project. I have built an eclipse how http://www.eclipse.org/webtools/jsf/...rce/index.html explains in section Milestone RC4 (Feature Freeze) that appears at the bottom of page.

        When I use eclipse 3.1.2 I can use my application correctly.

        Have you any idea about this type of problem?

        Thanks,
        Shaggy

        Comment


        • #5
          I assume is due to some classpath problem - probably you have some stale cache somewhere so your new classes are not being picked up or there is some configuration issue that doesn't read your binaries properly.
          I haven't encountered the issue myself so I can't give an accurate advice - try using 3.1.2 for the moment as Calisto will be out in a matter of days.

          Comment


          • #6
            Hello Costin,

            I have been reading much about Callisto. In less of 3 days we can develop whit it. In fact, I'm downloading a release to test and try to develop my application with it.

            If I have any problem with this project, I send you a post.

            Thanks for your replies,
            Shaggy.

            Comment

            Working...
            X