Announcement Announcement Module
No announcement yet.
VerifyError with IBM Linux PowerPC JDK 1.5 Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • VerifyError with IBM Linux PowerPC JDK 1.5

    Hi all,

    I have an application built on Spring that runs fine all all of the platforms I have tried it on (Mac OS X, Linux x86, Windows XP) until now, when I tried it on Linux PPC using the IBM Linux PPC JDK.

    Here is part of the error I am getting:

    java.lang.VerifyError: java.lang.NullPointerException
    at java.lang.J9VMInternals.verify( 61)
    at java.lang.J9VMInternals.verify( 53)
    at java.lang.J9VMInternals.initialize(J9VMInternals.j ava:124)
    at java.lang.Class.forNameImpl(Native Method)
    at java.lang.Class.forName(
    at org.springframework.util.ClassUtils.forName(ClassU
    at nitionReaderUtils.createBeanDefinition(BeanDefinit
    at org.springframework.beans.factory.xml.XmlBeanDefin itionParserHelper.parseBeanDefinitionElement(XmlBe
    at org.springframework.beans.factory.xml.XmlBeanDefin itionParserHelper.parseBeanDefinitionElement(XmlBe
    at org.springframework.beans.factory.xml.DefaultXmlBe anDefinitionParser.parseDefaultElement(DefaultXmlB
    at org.springframework.beans.factory.xml.DefaultXmlBe anDefinitionParser.parseBeanDefinitions(DefaultXml
    at org.springframework.beans.factory.xml.DefaultXmlBe anDefinitionParser.registerBeanDefinitions(Default
    at org.springframework.beans.factory.xml.XmlBeanDefin itionReader.registerBeanDefinitions(XmlBeanDefinit
    at org.springframework.beans.factory.xml.XmlBeanDefin itionReader.doLoadBeanDefinitions(XmlBeanDefinitio
    at org.springframework.beans.factory.xml.XmlBeanDefin itionReader.loadBeanDefinitions(XmlBeanDefinitionR
    at org.springframework.beans.factory.xml.XmlBeanDefin itionReader.loadBeanDefinitions(XmlBeanDefinitionR
    at BeanDefinitionReader.loadBeanDefinitions(AbstractB
    at BeanDefinitionReader.loadBeanDefinitions(AbstractB
    at icationContext.loadBeanDefinitions(XmlWebApplicati
    at icationContext.loadBeanDefinitions(XmlWebApplicati
    at hableApplicationContext.refreshBeanFactory(Abstrac
    at ationContext.refresh(AbstractApplicationContext.ja va:279)
    at freshableWebApplicationContext.refresh(AbstractRef
    at org.springframework.web.context.ContextLoader.crea teWebApplicationContext(
    at org.springframework.web.context.ContextLoader.init WebApplicationContext(
    at org.springframework.web.context.ContextLoaderListe ner.contextInitialized( 49)
    at com.caucho.server.webapp.Application.start(Applica
    at com.caucho.server.deploy.DeployController.startImp l(
    at com.caucho.server.deploy.DeployController.restartI mpl(
    at com.caucho.server.deploy.StartAutoRedeployAutoStra tegy.request( 5)
    at com.caucho.server.deploy.DeployController.request(
    at com.caucho.server.webapp.ApplicationContainer.getA pplication(
    at com.caucho.server.webapp.ApplicationContainer.buil dInvocation(
    at ava:424)
    at on(
    at com.caucho.server.resin.ServletServer.buildInvocat ion(
    at com.caucho.server.dispatch.DispatchServer.buildInv ocation(
    at com.caucho.server.http.HttpRequest.handleRequest(H
    at com.caucho.util.ThreadPool.runTasks(ThreadPool.jav a:507)
    at )

    Here is the configuration I am trying to run on:

    * Mac G4 with Yellow Dog Linux 4.1
    * Latest IBM JDK 5 for PowerPC Linux
    * Caucho Resin 3.0.19

    I am using the latest development release of Spring, (2.0 m4)

    Does anyone have any ideas why this is failing on Linux PowerPC Java?

    Any help would be greatly appreciated.


  • #2
    The exception does not seem to be related to the Spring Framework.

    I run into a weird bug some weeks before after migrating our application from SUN JDK 1.4 on Linux to IBM JDK 5 on Linux. It turned out that when a class is being loaded, IBM JDK checks all it dependencies. This "features" broke our application since we were using a 3rd party jar that had missing classes.


    • #3
      Thank you for your input on this.

      After a bit of additional testing, I was able to get an application to run under Tomcat.. But still no luck under Resin, which is what we normally run on. although Resin apps do seem to run as long as they don't use Spring. Even the basic app from the tutorial fails under Spring and Resin though, but works fine under Tomcat.

      Yes, it looks like the problem is in IBM's JRE. Was hoping maybe there was some kind of work around.