Announcement Announcement Module
Collapse
No announcement yet.
Error when trying to set Springframework-2.0-m3 as Eclipse project Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when trying to set Springframework-2.0-m3 as Eclipse project

    Classes TransactionSynchronizationManager and AbstractPlatformTransactionManager will not compile, with error 'The type javax.transaction.TransactionManager cannot be resolved. Indirectly referenced from required .class files'. Where do I get the javax.transaction.TransactionManager from?

  • #2
    See the lib folder and the readme file from the project root - it explains the jars that are contained and what purpose they serve. In your case you need jta.jar

    Comment

    Working...
    X