Announcement Announcement Module
Collapse
No announcement yet.
Spring 2.0 Java 1.4 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring 2.0 Java 1.4

    I think I posted to wrong forum-


    Is Spring 2.0 compatable with Java 1.4? Or does it use too many of the newe Java 5 features?

  • #2
    Spring 2.0 is compatible with jdk 1.3

    Comment


    • #3
      Spring (2.0 or 1.x series) is compatible with jdk1.3. Spring 2.0 however, needs to be compiled on a jdk 1.5 and but with the vm target set to 1.3. This is needed since some of the sources have annotations and a compiler that understands them is required - you can find more details about the building process if read the readme files on the CVS (where the all the Spring sources are placed along with the build scripts).

      Comment

      Working...
      X