Announcement Announcement Module
Collapse
No announcement yet.
Tomcat throws FileNotFoundException when importing resources=applicationContext.xml Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tomcat throws FileNotFoundException when importing resources=applicationContext.xml

    I am using Spring and Maven project. I have Project mit-webservices and mit-util project under mit-parent.

    mit-webservices is using mit-utils. I am importing applicationContext.xml of mit-utils from webapplicationContext.xml of mit-webservices as follows.

    Code:
    <import resource="classpath:mit/utils/shared/applicationContext.xml" />
    But when I run mit-webservices under Tomcat in Eclipse I get exception as

    Code:
    Jun 23, 2012 2:35:50 PM org.apache.catalina.core.AprLifecycleListener init
    INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java
    Jun 23, 2012 2:35:50 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
    WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.j2ee.server:vsm-webservices' did not find a matching property.
    Jun 23, 2012 2:35:50 PM org.apache.coyote.AbstractProtocol init
    INFO: Initializing ProtocolHandler ["http-bio-8080"]
    Jun 23, 2012 2:35:50 PM org.apache.coyote.AbstractProtocol init
    INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
    Jun 23, 2012 2:35:50 PM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 639 ms
    Jun 23, 2012 2:35:50 PM org.apache.catalina.core.StandardService startInternal
    INFO: Starting service Catalina
    Jun 23, 2012 2:35:50 PM org.apache.catalina.core.StandardEngine startInternal
    INFO: Starting Servlet Engine: Apache Tomcat/7.0.25
    Jun 23, 2012 2:35:51 PM org.apache.catalina.core.ApplicationContext log
    INFO: Initializing Spring root WebApplicationContext
    Jun 23, 2012 2:35:51 PM org.springframework.web.context.ContextLoader initWebApplicationContext
    INFO: Root WebApplicationContext: initialization started
    Jun 23, 2012 2:35:51 PM org.springframework.context.support.AbstractApplicationContext prepareRefresh
    INFO: Refreshing Root WebApplicationContext: startup date [Sat Jun 23 14:35:51 PDT 2012]; root of context hierarchy
    Jun 23, 2012 2:35:51 PM org.springframework.beans.factory.xml.XmlBeanDefinitionReader loadBeanDefinitions
    INFO: Loading XML bean definitions from class path resource [mit/webservices/webApplicationContext.xml]
    Jun 23, 2012 2:35:51 PM org.springframework.beans.factory.xml.XmlBeanDefinitionReader loadBeanDefinitions
    INFO: Loading XML bean definitions from class path resource [mit/utils/shared/applicationContext.xml]
    Jun 23, 2012 2:35:51 PM org.springframework.web.context.ContextLoader initWebApplicationContext
        SEVERE: Context initialization failed
        org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: Failed to import bean definitions from URL location [classpath:mit/utils/shared/applicationContext.xml]
        Offending resource: class path resource [mit/webservices/webApplicationContext.xml]; nested exception is org.springframework.beans.factory.BeanDefinitionStoreException: IOException parsing XML document from class path resource [mit/utils/shared/applicationContext.xml]; nested exception is java.io.FileNotFoundException: class path resource [mit/utils/shared/applicationContext.xml] cannot be opened because it does not exist
    In my mit-webservices have some junit test where I load mit-webservices/webapplicationContext file and it works very fine. But when I try to deploy mit-webservices under tomcat it throws above exception.

    I have also checked /lib dire of mit-webservices that mit-utils.jar does exist.

    I did mvn clean install and mvn eclipse:eclipse every time before deploy. I think tomcat not able to find mit-util in class path at deploy time but I do not have idea why it is happening.

    My WebApplicationContext.xml is

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <beans xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:aop="http://www.springframework.org/schema/aop" xmlns:tx="http://www.springframework.org/schema/tx"
        xmlns:context="http://www.springframework.org/schema/context"
        xmlns:util="http://www.springframework.org/schema/util" xmlns="http://www.springframework.org/schema/beans"
        xsi:schemaLocation="http://www.springframework.org/schema/beans 
               http://www.springframework.org/schem...-beans-3.0.xsd
               http://www.springframework.org/schema/context
               http://www.springframework.org/schema/context/spring-context-3.0.xsd">
    
    
        <import resource="classpath:mit/utils/shared/applicationContext.xml" />
    
        <context:component-scan base-package="mit" />
    
    </beans>
    and my web.xml in mit-webservices is

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <web-app version="2.5" xmlns="http://java.sun.com/xml/ns/javaee"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">
    
        <!-- Spring context -->
    
        <context-param>
            <param-name>contextConfigLocation</param-name>
            <param-value>classpath:mit/webservices/webApplicationContext.xml </param-value>
        </context-param>
    
        <listener>
            <listener-class>org.springframework.web.context.ContextLoaderListener</listener-class>
        </listener>
    
        <servlet>
            <servlet-name>ServletAdaptor</servlet-name>
            <servlet-class>com.sun.jersey.spi.spring.container.servlet.SpringServlet</servlet-class>
            <init-param>
                <param-name>com.sun.jersey.config.property.packages</param-name>
                <param-value>mit.webservices.jaxrs</param-value>
            </init-param>
            <load-on-startup>1</load-on-startup>
        </servlet>
        <servlet-mapping>
            <servlet-name>ServletAdaptor</servlet-name>
            <url-pattern>/resources/*</url-pattern>
        </servlet-mapping>
    
    </web-app>
    Thank You
Working...
X