Announcement Announcement Module
Collapse
No announcement yet.
Multiple Spring versions in an EAR Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Multiple Spring versions in an EAR

    Hi
    I have 2 web modules in an EAR

    I have old web Module 1 using Spring 2.5.6 and Spring Security 2.0.4

    Can I use Spring 3.1.1 and Spring security 3.1.0 in the new web module.

    Thanks

    VRB

  • #2
    Although you might get it to work (if the jars are part of the web module and not the ear) it still might lead to weird classloading issues (not on all app servers the web classloaders are as ignorant of other web app classloaders as they should resulting in classes from one app leaking into the the other).

    I personally would stick with the versions as used currently (and move the spring jars to the ear file).

    Comment


    • #3
      Thanks Marten

      Comment

      Working...
      X