Announcement Announcement Module
Collapse
No announcement yet.
Regarding in memory Authetication Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Regarding in memory Authetication

    hello friends,

    Please refer - http://forum.springsource.org/showth...-1-Please-Help for viewing the solution to this problem.

    i am developing new project with spring 3.1 and Spring security 3.1.
    I have developed one project earlier and have copied most of the config files from that.

    for testing page level security I plan to use in-memory authentication later actual database authentication can be used
    as i have done before.

    the part of security xml is as follows

    <security:authentication-manager>
    <security:authentication-provider>
    <security:user-service>
    <security:user name="owner" password="test" authorities="ROLE_OWNER" />
    <security:user name="ceo" password="test" authorities="ROLE_CEO" />
    <security:user name="srmgr" password="test" authorities="ROLE_SR_MGR" />
    <security:user name="mgr" password="test" authorities="ROLE_MGR" />
    <security:user name="opr" password="test" authorities="ROLE_OPR" />
    <security:user name="user" password="test" authorities="ROLE_USER" />
    </security:user-service>
    </security:authentication-provider>
    </security:authentication-manager>

    I tried to login but every time spring says bad credentials.

    the actual part of debug log is as follows.

    12:06:19 032 DEBUG No SecurityContext was available from the HttpSession: org.apache.catalina.session.StandardSessionFacade@ bb82ef9. A new one will be created.
    12:06:19 032 DEBUG /j_spring_security_check at position 3 of 10 in additional filter chain; firing Filter: 'LogoutFilter'
    12:06:19 032 DEBUG /j_spring_security_check at position 4 of 10 in additional filter chain; firing Filter: 'UsernamePasswordAuthenticationFilter'
    12:06:19 032 DEBUG Request is to process authentication
    12:06:19 033 DEBUG Authentication attempt using org.springframework.security.authentication.dao.Da oAuthenticationProvider
    12:06:19 033 DEBUG User '' not found

    it seems that spring is not getting proper username and password strings or in correct authentication manager is
    being called.
    the login form has j_username, j_password fields.


    Can somebody guide me what is wrong going on here ?

    Thanks and warm regards

    Raja
    Last edited by raja_s_patil; Dec 26th, 2011, 01:11 AM. Reason: Problem solved
Working...
X