Announcement Announcement Module
Collapse
No announcement yet.
Errors trying to build Spring from source on Win7 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Errors trying to build Spring from source on Win7

    Hi,

    I am trying to build Spring from the latest sources on Win7 and I get a few errors (see below). Please, can you point me to a solution ?

    Without admin rights, I get this error:

    Code:
       
       [junit] ------------- Standard Error -----------------
       [junit] 23-dÚc.-2011 17:35:45 java.util.prefs.WindowsPreferences openKey
       [junit] ATTENTION: Could not open windows registry node Software\JavaSoft\Prefs at root 0x80000002. Windows RegOpenKey(...) returned error code 5.
       [junit] 23-dÚc.-2011 17:35:45 java.util.prefs.WindowsPreferences openKey
       [junit] ATTENTION: Could not open windows registry node Software\JavaSoft\Prefs\my/System/Path at root 0x80000002. Windows RegOpenKey(...) returned error code 5.
       [junit] 23-dÚc.-2011 17:35:45 java.util.prefs.WindowsPreferences openKey
       [junit] ATTENTION: Could not open windows registry node Software\JavaSoft\Prefs\my/System/Path\mypath at root 0x80000002. Windows RegOpenKey(...) returned error code 5.
       [junit] ------------- ---------------- ---------------
       [junit] Testcase: testPreferencesPlaceholderConfigurer(org.springframework.beans.factory.config.PropertyResourceConfigurerTests):   Caused an ERROR
       [junit] Could not open windows registry node Software\JavaSoft\Prefs at root 0x80000002: Access denied
       [junit] java.lang.SecurityException: Could not open windows registry node Software\JavaSoft\Prefs at root 0x80000002: Access denied
       [junit]     at java.util.prefs.WindowsPreferences.openKey(WindowsPreferences.java:496)
       [junit]     at java.util.prefs.WindowsPreferences.openKey(WindowsPreferences.java:463)
       [junit]     at java.util.prefs.WindowsPreferences.openKey(WindowsPreferences.java:449)
       [junit]     at java.util.prefs.WindowsPreferences.putSpi(WindowsPreferences.java:595)
       [junit]     at java.util.prefs.AbstractPreferences.put(AbstractPreferences.java:234)
       [junit]     at org.springframework.beans.factory.config.PropertyResourceConfigurerTests.testPreferencesPlaceholderConfigurer(PropertyResourceConfigurerTests.java:728)
    Launching the ant build on a cmd window that has admin rights, I get this error instead:

    Code:
       [junit] Testcase: testSupports(org.springframework.oxm.jibx.JibxMarshallerTests):   Caused an ERROR
       [junit] Unable to access binding 'binding'
       [junit] Make sure classes generated by the binding compiler are available at runtime
       [junit] Unable to access binding 'binding'
       [junit] Make sure classes generated by the binding compiler are available at runtime
       [junit] java.lang.ClassNotFoundException: org.springframework.oxm.jibx.JiBX_bindingFactory
       [junit]     at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
       [junit]     at java.security.AccessController.doPrivileged(Native Method)
       [junit]     at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
       [junit]     at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
       [junit]     at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
       [junit]     at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
       [junit]     at org.jibx.runtime.BindingDirectory.getFactory(BindingDirectory.java:237)
       [junit]     at org.jibx.runtime.BindingDirectory.getFactory(BindingDirectory.java:292)
       [junit]     at org.springframework.oxm.jibx.JibxMarshaller.afterPropertiesSet(JibxMarshaller.java:224)
       [junit]     at org.springframework.oxm.jibx.JibxMarshallerTests.createMarshaller(JibxMarshallerTests.java:38)
       [junit]     at org.springframework.oxm.AbstractMarshallerTests.setUp(AbstractMarshallerTests.java:58)
       [junit]
    I'm using a 64 bits JDK version 1.6.0_30 (writting this, I wonder if the 64bits could be the cause ???)

    Thanks in advance for your help.

    And Merry XMas everybody!
Working...
X