Announcement Announcement Module
Collapse
No announcement yet.
Spring 3.1 Webapp that depends on jars with 2.5.6 help! Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring 3.1 Webapp that depends on jars with 2.5.6 help!

    I have a nice new spring 3.1.0.RC1 webapp using lots of the new spring 3 configuration and setup. I've been attempting to integrate a long-time existing api which is a jar comprised of spring 2.5.6 components that cannot be changed due to corporate policy at the moment. I really do not want to re-configure and redo my app to be 2.5.6 because the new 3.1 stuff is extremely convenient.

    Is there any way this configuration is able to work? Currently the errors being thrown have to due with clashing namespaces of the xml. My webapp spring config has to import external spring configs from the jars that are using 2.5.6 so it isn't enjoying that very much.

    Is there a way to isolate the classpath somehow or shoehorn the 2.5.6 stuff into my app to get it to run?

    Any help would be greatly appreciated!!
Working...
X