Announcement Announcement Module
Collapse
No announcement yet.
spring boot with spring 3.2.4.RELEASE Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • spring boot with spring 3.2.4.RELEASE

    Hi

    How can I change the spring framework version to 3.2.4.RELEASE in the sample code used for "Building a RESTful Web Service" http://spring.io/guides/gs/rest-service

    I add the following the build.gradle dependencies section
    Code:
     compile("org.springframework:spring-webmvc:3.2.4.RELEASE")
    With the
    Code:
     ./gradlew -q dependencies
    I see that
    Code:
    +--- org.springframework:spring-webmvc:3.2.4.RELEASE -> 4.0.0.M3
    |    +--- org.springframework:spring-beans:4.0.0.M3
    |    |    \--- org.springframework:spring-core:4.0.0.M3
    |    |         \--- commons-logging:commons-logging:1.1.1
    |    +--- org.springframework:spring-context:4.0.0.M3
    |    |    +--- org.springframework:spring-aop:4.0.0.M3
    |    |    |    +--- aopalliance:aopalliance:1.0
    |    |    |    +--- org.springframework:spring-beans:4.0.0.M3 (*)
    |    |    |    \--- org.springframework:spring-core:4.0.0.M3 (*)
    |    |    +--- org.springframework:spring-beans:4.0.0.M3 (*)
    |    |    +--- org.springframework:spring-core:4.0.0.M3 (*)
    |    |    \--- org.springframework:spring-expression:4.0.0.M3
    |    |         \--- org.springframework:spring-core:4.0.0.M3 (*)
    |    +--- org.springframework:spring-core:4.0.0.M3 (*)
    |    +--- org.springframework:spring-expression:4.0.0.M3 (*)
    |    \--- org.springframework:spring-web:4.0.0.M3
    ...
    However when I run the
    Code:
     ./gradlew build
    the build/libs/gs-rest-service-0.1.jar contains the 4.0.0.M3 spring artifacts and NOT the spring 3.2.4.RELEASE artifacts.

    Somehow the spring-boot-gradle-plugin is not picking up the correct artifacts from classpath? Or do I miss here something?

    Thank you in advance.
    Last edited by altfatterz; Oct 22nd, 2013, 06:29 PM. Reason: springboot, version, classpath, gradle plugin

  • #2
    I'd love to know if Spring Boot can be used with Spring 3.2. I have tried briefly with an existing app and have had no luck, but it could definitely be operator error.

    Comment


    • #3
      Spring Boot requires Spring 4

      Comment

      Working...
      X