Announcement Announcement Module
Collapse
No announcement yet.
WorkManagerTaskExecutor not working as expected Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • WorkManagerTaskExecutor not working as expected

    Hello All
    I am using Spring batch with task executor - WorkManagerTaskExecutor. My application is deployed in WebSphere Application Server 6.2 (ND deployment)
    I created a new JNDI wm/batch using WebSphere console with the minimum thread as 5 and maximum thread as 10.
    But WebSphere never provides more than 5 threads for the batch to execute. I checked both through application and through WebSphere console and it is always never more than 5.
    I then increased minimum thread to 10 and maximum thread to 15 assuming that the Websphere is not able to create more than minimum thread. But the batch never runs more than 5 threads
    I have already taken care of states by extending readers and and making the entire batch thread safe.
    Please can you help me in trying to solve this problem.
    Thanks
    Warm Regards
    Prashant Maroli

  • #2
    You are using a TaskExecutor inside a Step or in a PartitionStep? Did you set the throttle limit? See docs at http://static.springsource.org/sprin...alability.html.

    Comment


    • #3
      Yes Problem Solved

      Dear Dave Syer
      You got it right. The problem was the throttle limit. Once I set it to 20 and it worked like a charm.
      We are using task executor inside a step. We were so involved with troubleshooting around the configuration using WebSphere Console and the application code that we missed looking into the throttle limit.
      Our batch program now scales very well.
      I am keen to now try out my hand on Partition step as well.

      Thanks a lot for the help.
      Warm Regards
      Prashant

      Comment

      Working...
      X