Announcement Announcement Module
Collapse
No announcement yet.
Problem with dependencies? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with dependencies?

    Hello,

    I've recently started investigating Spring Batch and I have come across some dependency issues:

    I declare the following dependency in my pom.xml (which I believe is the latest release):
    Code:
    <dependency>
    	<groupId>org.springframework.batch</groupId>
    	<artifactId>spring-batch-core</artifactId>
    	<version>2.1.2.RELEASE</version>
    	<type>jar</type>
    	<scope>compile</scope>
    </dependency>
    However, in the dependency graph (in STS) I can see that the spring-batch-core depends on spring-context-2.5.6 and not on the latest 3.0.3 version.

    This unfortunately, is causing me problems as I would like to use some 3.0.3 features of the ApplicationContext classes (such as SpEL and the newest method signatures).

    Can anyone suggest any solutions?

    Thank you,
    Savvas.

  • #2
    ..I also meant to mention that obviously, this all refers to dependency management using Maven..

    Comment


    • #3
      Include spring 3 and it should work fine...

      Comment


      • #4
        Hi Marten,

        Thanks for your reply.

        When you say "include Spring 3"? I didn't have to specify any spring core libs explicitly as they are "pulled" from the core-batch's definition..

        Comment


        • #5
          Specify an EXPLICIT spring version yourself and that will be used instead of the one pulled as a dependency!

          Comment


          • #6
            ok, got that!

            thanks very much,
            Savvas.

            Comment

            Working...
            X