Announcement Announcement Module
Collapse
No announcement yet.
Schema Validation Errors? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Schema Validation Errors?

    Hiya,

    I was just trying to assemble a job and am getting the following errors:

    Code:
    <bean class="org.springframework.batch.item.database.JdbcBatchItemWriter">
    	<property name="dataSource" ref="dataSource" />
    	<property name="sql" value="" />
    	<property name="itemSqlParameterSourceProvider">
    		<bean class="org.springframework.batch.item.database.BeanPropertyItemSqlParameterSourceProvider" />
    	</property>
    </bean>
    Code:
    Description	Resource	Path	Location	Type
    No setter found for property 'dataSource' in class 'org.springframework.batch.item.database.JdbcBatchItemWriter'	applicationContext.xml	/company-batch-dupmac/src/main/resources	line 67	Spring Beans Problem
    No setter found for property 'itemSqlParameterSourceProvider' in class 'org.springframework.batch.item.database.JdbcBatchItemWriter'	applicationContext.xml	/company-batch-dupmac/src/main/resources	line 69	Spring Beans Problem
    No setter found for property 'sql' in class 'org.springframework.batch.item.database.JdbcBatchItemWriter'	applicationContext.xml	/company-batch-dupmac/src/main/resources	line 68	Spring Beans Problem
    Is this a problem with my schema? Here are the declarations:

    Code:
    <beans xmlns="http://www.springframework.org/schema/beans"
    	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    	xmlns:batch="http://www.springframework.org/schema/batch"
    	xmlns:context="http://www.springframework.org/schema/context"
    	xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-2.5.xsd
    		http://www.springframework.org/schema/batch http://www.springframework.org/schema/batch/spring-batch-2.0.xsd
    		http://www.springframework.org/schema/context http://www.springframework.org/schema/context/spring-context-2.5.xsd">
    Thanks.

    Keith

  • #2
    Hi,

    Please try with below schema,

    <beans:beans xmlns="http://www.springframework.org/schema/batch"
    xmlns:beans="http://www.springframework.org/schema/beans"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="
    http://www.springframework.org/schema/beans
    http://www.springframework.org/schem...-beans-2.0.xsd
    http://www.springframework.org/schema/batch
    http://www.springframework.org/schem...-batch-2.0.xsd
    ">


    /Murugesan

    Comment


    • #3
      Thanks...

      That worked by my question is why? If I am using Spring 2.5.6.SEC01 shouldn't I be using beans schema 2.5?

      Thanks.

      Keith

      Comment

      Working...
      X