Announcement Announcement Module
Collapse
No announcement yet.
Spring Batch 2.x Dependencies Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Batch 2.x Dependencies

    I saw in the link: http://static.springsource.org/sprin...ighlights.html that Spring Batch 2.0 will target for Spring 3.0

    My application is using spring 2.5.6 and will not upgrade to spring 3.0 in near future. Is it suitable for us to use Spring Batch 2.0?

  • #2
    Spring Batch 2.0 depends on Spring 2.5.6. 3.0 is an option with 2.0.2, but not mandatory. I should clarify that web page a bit.

    Comment


    • #3
      Thanks to clarification. That means I can still enjoy most of core features of SB 2.x without upgrade to Spring 3.0.

      One more question, is there any plan to make Spring 3.0 mandatory in some future release of SB 2.x? If the answer is yes, I think I may not be able to adopt Spring Batch in our case.

      Comment


      • #4
        Definitely not in 2.0.x. Maybe later. Maybe not (if we can make it optional we will).

        Comment

        Working...
        X