Announcement Announcement Module
Collapse
No announcement yet.
Build problem when using 1.0.1.RELEASE Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Build problem when using 1.0.1.RELEASE

    Our application now build depend on SB 1.0.1.RELEASE and Spring 2.5.4. We found that the SB 1.0.1.RELEASE hard coded to depend on Spring 2.5.2. in spring-batch-1.0.1.RELEASE.pom, which is out of our expectation.

    Code:
    	<properties>
    		<maven.test.failure.ignore>true</maven.test.failure.ignore>
    		<spring.framework.version>2.5.2</spring.framework.version>
    	</properties>
    
    	<dependency>
    		<groupId>org.springframework</groupId>
    		<artifactId>spring-context</artifactId>
    		<version>${spring.framework.version}</version>
    	</dependency>
    Given this, we got the error of missing 2.5.2 dependencies when building our project as our repository only have Spring 2.5.4.

    Of course, we can add 2.5.2 deps also but we don't think this is a desirable behavior. Please advise.

  • #2
    This is really a Maven question - not much to do with Spring Batch per se. We do of course expect 2.5.4 to work fine, but it wasn't tested by us. 1.1 is now building and testing against 2.5.5.

    To use Maven to build an application that depends on Spring Batch 1.0.1 and Spring 2.5.4, you may have to do two things. At the least you need to specify the Spring dependencies in your own POM with the correct version. That should be enough, but if any of the Spring packages changed their names or mandatory dependencies between 2.5.2 and 2.5.4 (I hope they didn't if you are using the same repo) you might need to add some exclusions to the Spring Batch dependency in your own POM as well.

    Comment

    Working...
    X