Announcement Announcement Module
Collapse
No announcement yet.
Spring batch jars for java version 1.4? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring batch jars for java version 1.4?

    Hi,

    Whether spring batch jars for java version 1.4 is available?
    Am using java version 1.4 so am unable to use spring batch jars which is built using java version 1.5.

    Can anybody help me out?
    Thanks in advance

  • #2
    What version of the jars do you have? We have a CI build for the samples that runs with 1.4, and rc1 was out yesterday passing that build.

    Comment


    • #3
      Hi ,
      Am having the spring batch jars of 1.0.0.m4-with-dependencies.
      i got tat from below link

      http://static.springframework.org/do...?project=BATCH

      Comment


      • #4
        What specific error are you getting when trying to use them?

        Comment


        • #5
          Am getting NoclassDefFoundError. Java 1.4 doesn't have StringBuilder class

          java.lang.NoClassDefFoundError: java/lang/StringBuilder
          at org.springframework.batch.execution.repository.dao .JdbcJobDao.createJ
          obKey(JdbcJobDao.java:142)
          at org.springframework.batch.execution.repository.dao .JdbcJobDao.findJob
          Instances(JdbcJobDao.java:197)
          at org.springframework.batch.execution.repository.Sim pleJobRepository.cr
          eateJobExecution(SimpleJobRepository.java:156)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.
          java:85)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.
          java:58)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAcces
          sorImpl.java:60)
          at java.lang.reflect.Method.invoke(Method.java:391)
          at org.springframework.aop.support.AopUtils.invokeJoi npointUsingReflecti
          on(AopUtils.java:301)

          Comment


          • #6
            Can't you just upgrade to rc1?

            Comment


            • #7
              yes we are about to use rc1.

              Comment

              Working...
              X