Announcement Announcement Module
Collapse
No announcement yet.
Is Spring Batch JDK 1.7 compatible? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is Spring Batch JDK 1.7 compatible?

    Hi,

    JDK 1.7 includes JDBC 4.1, so I was wondering whether Spring Batch is compatible with JDK 1.7 or not. Current stable 2.1.8 or 2.2.0-SNAPSHOT?

    Regards,
    Shantanu
    Last edited by shantanu_k06; Dec 18th, 2011, 08:16 AM. Reason: fix typo

  • #2
    Is JDK 1.7 compatible with the previous versions of Java. Does it work where JDK1.6 used to work? Will it work where JDK1.5 used to work?

    To cut a long story short Spring Batch should work on any JDK 1.5+ platform (depends on the version of spring you are using too).

    Why do you think JDBC 4.1 would have any impact?

    Comment

    Working...
    X