Announcement Announcement Module
Collapse
No announcement yet.
weaver option '-Xset:weaveJavaxPackages=true' has not been specified Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • weaver option '-Xset:weaveJavaxPackages=true' has not been specified

    Hi,

    I try to define a spring 3 aop pointcut at the jpa EntityManger.persist() . So I start my tomcat with the spring agent and set the the loaderClass to TomcatInstrumentableClassLoader in the meta-inf/context.xml. and in springs applicationContext.xml I add the <load-time-weaver> tag.
    If I got it right to enable the weaving in javax.persitence.EntityManger I have to set "-Xset:weaveJavaxPackages=true" in the meta-inf/aop.xml. So I have in this file
    HTML Code:
    <aspectj>
    	<weaver options="-Xset:weaveJavaxPackages=true">		
    		<include within="my.app.*"/>
    		<include within="javax.persistence.*"/>
    	</weaver>
    	<aspects>
    		<aspect name="my.app.MyAspect" />
    	</aspects>
    </aspectj>

    but still when I start my tomcat I get the message:

    HTML Code:
    [TomcatInstrumentableClassLoader@1b83048] warning javax.* types are not being woven because the weaver option '-Xset:weaveJavaxPackages=true' has not been specified

    Any Ideas?

    thanks in advance
    max

  • #2
    What happens if you use -javaagent:/path/to/aspectjweaver.jar as a way of enabling LTW?

    -Ramnivas

    Comment


    • #3
      Originally posted by ramnivas View Post
      What happens if you use -javaagent:/path/to/aspectjweaver.jar as a way of enabling LTW?

      -Ramnivas

      I got the same warning message in my log even when using -javaagent:/path/spring-instrument.jar. I simply ignore it.

      Comment

      Working...
      X