Announcement Announcement Module
Collapse
No announcement yet.
Spring IDE 2.0 released Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring IDE 2.0 released

    Dear Spring Community,

    after fixing approximately 250 bugs and working uncountable hours on adding support for Spring 2.0, Spring Web Flow, Spring AOP and Spring JavaConfig, we are proud to announce the immediate availability of Spring IDE 2.0.


    The release is available from our release update site. Spring IDE 2.0 is licensed under the terms of the Eclipse Public License - v1.0.

    New Features

    Spring IDE 2.0 contains lots of new features and a bunch of bug fixes. A list of all closed tickets is available in our ticketing system. For those of you that are not familiar with recent development of Spring IDE here is a short list of features included:
    • Support for Spring 2.0 namespace-based configurations. We have put lots of work into that to make the support as extensible as possible. You can read more about that in another post.
    • Support for Spring Web Flow, including an extension to WTP’s XML editor for content assist and hyperlinking as well as validation and graphical editing. More information is available here.
    • Tools for Spring AOP based development. This includes support for validating configurations (parsing of pointcut expressions) and visualization of cross cutting references based on <aop:config> and @AspectJ-style aspects.
    • Support for Spring JavaConfig M2. This serves as sandbox for testing the extension points of Spring IDE’s core. Read more about that here and here.
    • Usability and UI improvements: A new Spring Explorer that replaces the Beans View, Content contribution to the Eclipse’s Project Explorer, a Spring Working Set type to reduce cluttering in the Project and Spring Explorer, Refactoring participants for rename and move refactorings of Java Packages and Classes as well as Bean names, New Project and Spring Bean configuration file wizard.

    Spring IDE 2.0 is compatible with upcoming Eclipse 3.3 (aka Eclipse Europa).

    Read more at the Spring IDE Blog.

    Cheers
    Torsten & Christian
Working...
X