Announcement Announcement Module
Collapse
No announcement yet.
Spring OSGi 1.0 M2 released Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring OSGi 1.0 M2 released

    Dear Spring community,

    I'm pleased to announce that Spring OSGi 1.0 M2 has been released.
    Downloads | JavaDocs


    Spring OSGi 1.0 M2 is an update to 1.0 M1 release, fixing compatibility issues against Spring 2.0.4 along with a simplified Maven configuration and greatly improved OSGi manifests for Spring jars.


    The next release (1.0 M3) will be the last milestone and is scheduled for end of June/early July.


    The full roadmap can be found here.


    Feedback on new or existing features is appreciated.


    Cheers!
    Costin Leau
    Interface21 - http://www.interface21.com

  • #2
    Is Spring-OSGI 1.0m2 Mule(Equinox) ready?

    I have a great interest to see OSGi being fully integrated with Spring, and have follow the online documentation and various forum to try to get Mule to run spring 2.1 with OSGi support, but after hitting 1 wall against another, I am really frustrated with my progress so far. So I came here to ask the development community. Is Spring-OSGi ready to be integrated with mule yet? If so can you provide me with some hint on how to go about it.

    What I have Done so far:
    1) created 2 simple UMO in mule using spring container, and added osgi service and reference tags to them to see if they can be dynamically loaded and unloaded
    2) copy and hosted the spring-osgi.xsd schema on my local machine, to get the spring binding xml file to pass sax validation
    3) added spring-osgi-core, spring-osgi-extender, spring-osgi-lib, framework jar to the mule\lib\opt directory

    Right now i am stuck on the error given to me by mule start up:
    -Caused by: org.springframework.beans.factory.BeanCreationExce ption: Error creating bean with name 'org.springframework.osgi.service.exporter.OsgiSer viceFactoryBean': Invocation of init method failed; nested exception is java.lang.IllegalArgumentException: required property 'bundleContext' has not been set

    Has anyone else try to get Spring-OSGi working with mule yet? Is this the right forum to ask this question?

    Comment

    Working...
    X