Announcement Announcement Module
Collapse
No announcement yet.
Roo 1.1.0.RELEASE Problem Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi, has anyone gotten this working? If so, is there a walkthru/tut that you could throw up here? Have experienced the same problems, not really sure even where to start with the maven3 branch.

    TIA

    Comment


    • #17
      Originally posted by yqu View Post
      For all surf eclipse plugins, you can try the DEV_MAVEN3 branch. It will require maven 3 but it gives us a clean way for eclipse related dependencies. The final build result is a local eclipse update site which will can install to STS 2.5.1.
      Hi, I'm trying this route, please help as I was unsuccessful. Following this guide, http://www.springsurf.org/sites/1.0....velopment.html, I checked out from branches/DEV_MAVEN3. from the command prompt (I'm on Mac OS X btw), i run
      Code:
      mvn install
      , but get the following error:


      Code:
      [INFO] Building Maven Default Project
      [INFO]    task-segment: [install]
      [INFO] ------------------------------------------------------------------------
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Cannot execute mojo: resources. It requires a project with an existing pom.xml, but the build is not using one.
      any ideas? thanks in advance

      Comment


      • #18
        Originally posted by yqu View Post
        For all surf eclipse plugins, you can try the DEV_MAVEN3 branch. It will require maven 3 but it gives us a clean way for eclipse related dependencies. The final build result is a local eclipse update site which will can install to STS 2.5.1.
        Hi yqu, thanks for the help. I was able to chechout and build from DEV_MAVEN3, but I'm not sure how to install that as an update site. I'm running STS 2.5.2 Any help here appreciated.
        thanks, gene

        Comment


        • #19
          Hi, Gene

          Once you get everything built, you should have a local update site under

          DEV_MAVEN3/trunk/spring-surf-devtools/spring-surf-eclipse-extensions/spring-surf-update-site/target/site

          and you can open STS 2.5 and create a local update site and point it to that directory.

          Yong

          Comment


          • #20
            Hmm... I build the normal trunk successfully.
            But i dont have this update site you're talking about.
            Can anyone help me?

            EDIT: Ok, got the Site... now Freemarker 1.1.0 is missing....any idea?
            EDIT: Installed Freemarker... but where is the Roo addon now?
            Last edited by kazimir; Jan 25th, 2011, 11:33 AM.

            Comment


            • #21
              Hi all,

              I'm trying to setup spring surf environment, and it leads me to this thread.

              My purpose is to setup spring surf envi with roo, and start developing a site to be deployed inside alfresco record management.

              I have installed STS 2.6.0, maven 3.0.3 , and spring-roo-1.1.2.RELEASE which is bundled with STS

              I've already done SVN checkout from DEV_MAVEN3/trunk
              Now i'm stuck when I run 'mvn install' command

              There are warnings :

              Code:
              [WARNING] Some problems were encountered while building the effective model for org.springframework.extensions.surf:spring-surf-roo-addon:bundle:1.0.0.CI-SNAPSHOT
              [WARNING] The expression ${pom.version} is deprecated. Please use ${project.version} instead.
              [WARNING] The expression ${pom.artifactId} is deprecated. Please use ${project.artifactId} instead.
              [WARNING] The expression ${pom.organization.name} is deprecated. Please use ${project.organization.name} instead.
              [WARNING] The expression ${pom.organization.name} is deprecated. Please use ${project.organization.name} instead.
              [WARNING] The expression ${pom.url} is deprecated. Please use ${project.url} instead.
              [WARNING]
              and exception :
              Code:
              [INFO] Adding repository (cached) http://springide.org/updatesite
              [WARNING] Exception reading bundle manifest
              java.util.zip.ZipException: error in opening zip file
                      at java.util.zip.ZipFile.open(Native Method)
                      at java.util.zip.ZipFile.<init>(ZipFile.java:114)
                      at org.codehaus.tycho.osgitools.DefaultBundleReader.doLoadManifest(DefaultBundleReader.java:85)
                      at org.codehaus.tycho.osgitools.DefaultBundleReader.loadManifest(DefaultBundleReader.java:47)
                      at org.codehaus.tycho.osgitools.EquinoxResolver.loadManifest(EquinoxResolver.java:199)
                      at org.codehaus.tycho.osgitools.EquinoxResolver.addBundle(EquinoxResolver.java:175)
                      at org.codehaus.tycho.osgitools.EquinoxResolver.newState(EquinoxResolver.java:157)
                      at org.codehaus.tycho.osgitools.EquinoxResolver.newResolvedState(EquinoxResolver.java:52)
                      at org.codehaus.tycho.osgitools.OsgiBundleProject.getResolverState(OsgiBundleProject.java:194)
                      at org.codehaus.tycho.osgitools.OsgiBundleProject.resolve(OsgiBundleProject.java:142)
                      at org.codehaus.tycho.resolver.DefaultTychoDependencyResolver.resolveProject(DefaultTychoDependencyResolver.java
              :80)
                      at org.codehaus.tycho.maven.TychoMavenLifecycleParticipant.afterProjectsRead(TychoMavenLifecycleParticipant.java
              :94)
                      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:273)
                      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
                      at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
                      at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
                      at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
                      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                      at java.lang.reflect.Method.invoke(Method.java:597)
                      at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
                      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
                      at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
                      at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
              [ERROR] Internal error: java.lang.NullPointerException -> [Help 1]
              org.apache.maven.InternalErrorException: Internal error: java.lang.NullPointerException
                      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:168)
                      at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
                      at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
                      at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
                      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                      at java.lang.reflect.Method.invoke(Method.java:597)
                      at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
                      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
                      at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
                      at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
              Caused by: java.lang.NullPointerException
                      at org.eclipse.osgi.internal.resolver.StateBuilder.createBundleDescription(StateBuilder.java:44)
                      at org.eclipse.osgi.internal.resolver.StateObjectFactoryImpl.createBundleDescription(StateObjectFactoryImpl.java
              :32)
                      at org.codehaus.tycho.osgitools.EquinoxResolver.addBundle(EquinoxResolver.java:177)
                      at org.codehaus.tycho.osgitools.EquinoxResolver.newState(EquinoxResolver.java:157)
                      at org.codehaus.tycho.osgitools.EquinoxResolver.newResolvedState(EquinoxResolver.java:52)
                      at org.codehaus.tycho.osgitools.OsgiBundleProject.getResolverState(OsgiBundleProject.java:194)
                      at org.codehaus.tycho.osgitools.OsgiBundleProject.resolve(OsgiBundleProject.java:142)
                      at org.codehaus.tycho.resolver.DefaultTychoDependencyResolver.resolveProject(DefaultTychoDependencyResolver.java
              :80)
                      at org.codehaus.tycho.maven.TychoMavenLifecycleParticipant.afterProjectsRead(TychoMavenLifecycleParticipant.java
              :94)
                      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:273)
                      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
                      ... 11 more
              Please kindly advise, where did i go wrong in these steps?
              I've googled around, and yet found a solution to this matter.
              Many thanks in advance
              Last edited by msbee; Apr 7th, 2011, 02:30 AM. Reason: better format

              Comment


              • #22
                Hi,

                Any chances Surf addon will be fixed for the Roo 1.1-releases ? Looking at the Jira I can't find any activity on addons beside the Webscript addon SESURF-1. Greate Dev Tool so please keep up the good work.

                Regards,
                Amine

                Comment

                Working...
                X