Announcement Announcement Module
Collapse
No announcement yet.
STS-2.3.2 + spring-surf-sts-addon_1.0.0.M3 don't work Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS-2.3.2 + spring-surf-sts-addon_1.0.0.M3 don't work

    Hi,

    my Spring-surf-sts-addon is not recognized by STS.

    I did a copy of "spring-surf-sts-addon_1.0.0.M3.jar" in the plugin directory.

    Well, when i want to create a new "spring-template-project" the "surf-template" doesn't appear.

    Can you help me please

  • #2
    same issue here.

    has it maybe something to do with the plugin being "unsigned"?

    any pointers greatly appreciated...

    regards,
    frank

    Comment


    • #3
      STS plugin not working

      Same issue here. I'm using sts-2.3.2.RELEASE and spring-surf-sts-addon_1.0.0.M3.jar, and the Surf template isn't showing up.

      Comment


      • #4
        Same issue here too.

        I'm using STS 2.3.2 and spring-surf-sts-addon_1.0.0.M3.jar
        on OSX 10.6.

        Some Alfresco server has stopped, hasn't it?
        I got 404 error, when I accessed below via browser
        http://www.springsurf.org/alfresco/s...HOT?guest=true

        Comment


        • #5
          STS-2.3.2 + spring-surf-sts-addon_1.0.0.M3 will work

          guys i to have the same issue... but i think i have found the solution for it....

          to reflect surf template project into your project... please follow the below steps...

          frist please check that if you have a .sts folder in your \workspace-sts-2.5.0.M3\.metadata\

          if the .sts folder not exist in the above path... you will not be able to have surf template project in your project.


          please mail me to [email protected] to send you across the .sts folder.

          This error is due to the update of the file 1.0.0.CI-SNAPSHOT.

          as this file is updated the issue raised and when we checked into the folder structure we are missing the .sts folder we compared to the earlier version.

          so we have added the folder into our workspace and then we are able to create a surf template project....


          the above solution will only help you to create the surf template project.

          but it will not run until you change the pom.xml

          Comment


          • #6
            Thank you for your reply

            What you said is creating .sts folder under workspace of STS, is it right?

            I tried that, but situation has not changed..

            And I try some combination of sts and surf, but all failed

            sts 2.3.1 and surf M2
            sts 2.3.1 and surf M3
            sts 2.3.1 and surf 1.0.0CI
            sts 2.3.2 and surf M3
            sts 2.3.2 and surf 1.0.0CI
            sts 2.3.2 and surf 1.0.0RC1
            sts 2.5.0M3 and surf 1.0.0CI
            sts 2.5.0M3 and surf 1.0.0RC1

            Regards

            Comment


            • #7
              Hello, I'm having the same issue.

              STS Version: 2.3.2.RELEASE + spring-surf-sts-addon_1.0.0-RC1.jar in the plugins folder inside STS installation directory.

              In the workspace, I have the .sts folder under the .metadata. Althought I have the Spring MVC Project template, not the Surf Project Template, does anyone has the folder Surf Project Template Folder, if yes could you send it?

              Comment


              • #8
                Solution for STS-2.3.2 + spring-surf-sts-addon_1.0.0.M3

                The solution is not to create a .sts folder in your workspace, because it has to have some more folders and files in that.


                Please install the STS 2.5.0M3 and surf 1.0.0.CI-Snapshot

                After installing you need to have the following structure.
                \workspace-sts-2.5.0.M3\.metadata\.sts\content\org.springframewor k.extensions.sts.surf-1.0.0.CI-SNAPSHOT\
                In the folder org.springframework.extensions.sts.surf-1.0.0.CI-SNAPSHOT\ you will have the following files.
                1)template.xml
                2)template.zip
                3)wizardui.json

                Once if you are able to have the above folder your surf template project will be appeared in the STS.

                But to make the surf template project work you need to change the pom.xml file with the following values because it downloads the updated lib files which are not matching our configuration.

                The default value will be
                <properties>
                <surfVersion>1.0.0.CI-SNAPSHOT</surfVersion>
                <springVersion>3.0.0.RELEASE</springVersion>
                <aspectjVersion>1.6.6.RELEASE</aspectjVersion>
                </properties>

                Please change it to the below
                <properties>
                <surfVersion>1.0.0.M3</surfVersion>
                <springVersion>3.0.0.RELEASE</springVersion>
                <aspectjVersion>1.6.6.RELEASE</aspectjVersion>
                </properties>



                I could not attach the files but if you like to have the files please email me to [email protected]

                Comment


                • #9
                  to2y's orignal assertion that a server was down at www.springsurf.org was correct. It's now been restarted, apologies for us not sorting this out sooner. The quickest way to check if this is the case is just to try the URL: http://www.springsurf.org/alfresco/s...HOT?guest=true (for the time being anyway, this may get changed in the future).

                  My understanding is that new Spring Templates provided in a JAR only define a URL from which to retrieve the actual template information and this is then downloaded the first time it is needed. This does rely on the URL being available.

                  Comment


                  • #10
                    @ddraper
                    is this URL correct now? It does not work, should it be restarted again?

                    @indra
                    Indra, are you willing to send your files that resolve this issue?

                    Comment


                    • #11
                      I too have the same problem

                      Hi All,
                      Everything goes fine. but when i want to create a new "spring-template-project" the "surf-template" doesn't appear.
                      Please help me out

                      Comment


                      • #12
                        I have the save issue.
                        I've downloaded "roo 1.2.1" and tried to install "spring-surf-roo-addon-1.0.0.CI-SNAPSHOT-roo-addon.zip" downloaded from the SpringSurf.org site and I get an error of "addon install" not found or if i use roo's "osgi" command with the spring-surf-sts-addon_1.0.0.CI-SNAPSHOT.jar I still can't get Surf to run in roo or STS "springsource-tool-suite-2.8.1.RELEASE-e3.7.1-macosx-cocoa-x86_64-installer.dmg". However, I did get surf addon in roo working.
                        Last edited by raldermanfl; Mar 5th, 2012, 06:17 PM.

                        Comment


                        • #13
                          To get surf addon into roo you must download and install roo version SpringRoo: 1.0.2.RELEASE [rev 638] from http://www.springsource.org/ and copy and paste the SpringSurf 1.0.0.CI-SNAPSHOT link from http://www.springsurf.org/ into the roo command line for the roo "addon install" command.

                          Comment


                          • #14
                            Same issue here too.

                            I'm using STS 2.3.2 and spring-surf-sts-addon_1.0.0.M3.jar
                            on OSX 10.6.

                            Comment

                            Working...
                            X